After install, Brave will not launch correctly (Win10 64 bit)

I have Brave installed on my personal laptop and my iPhone Xr with no issues. I had Brave installed on my work laptop (Win7) also with no problems. I received a new laptop at work (64 bit Win10). Brave will not work. I’ve tried multiple installs/uninstalls. Every time the install appears to install completely and correctly. After each install when I initially launch Brave I receive the “aw snap” message. I don’t think this is an install error rather than a crash, per se, because the browser will not load any webpage. Literally nothing works in the browser. Is there something specific to Win10 that would cause problems that didn’t occur on iOS, or Win7?

I have a similar problem. That’s how looks Brave’s window. There’s nothing inside. And after all undelete also doesn’t work.

1 Like

Under Brave Properties/Compatibility I ran “Run compatibility troubleshooter” for Windows 8. Brave immediately loaded and worked properly. I’m not sure what to make of this. Since v1.4.96 doesn’t work on my laptop, does anyone know to download v1.4.95 which is working on my other laptop?