Brave shields are blocking Gmail

Description of the issue:
I cannot login to gmail when the brave shields are up. It shows error 400.
If I turn off the shields then gmail is working as expected.
Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)
Does the site function as expected when Shields are turned off?
Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
I don’t know. I have attached a photo of my shields settings.
Does the site work as expected when using Chrome?
Brave version (check About Brave):

I should also add that I have cleared all cookies from the browser and I have restarted Brave but the problem appears again.

I see elsewhere that you can either have shields down or allow all cookies. Neither workaround is an acceptable permanent solution.

I’m having the same issue. It just started happening today… I have been opening from a bookmark.

V1.37.116 (Apr 14, 2022)

@sierrapapa @privacy69 Welcome to the community. :slightly_smiling_face:

This is a known issue. Post by Mattches in a similar topic below. I get this too and it is irritating! I hope they find a fix!

There is another workaround, more involved, but I think it allows you to leave shields up. I didn’t use because I don’t want to have to go back later and modify settings again. You can look it over and see if it is something you want to try.

Can anyone here experiencing this issue perform a test to narrow down the culprit here by:

  1. visiting brave://flags

  2. Searching for a flagged called Enable First Party Ephemeral Storage and set it’s value to Disabled

  3. Relaunch the browser

  4. Ensure Shields settings are set to default for the site (if they were changed at all)

  5. Test going to Gmail again

1 Like


I just tested it and it works!
I set the flag to Disabled from Default and relaunched the browser.
Gmail is now opening fine with shields up.

Is this a temporary solution? should I leave the flag to disabled or turn it back to Default?

1 Like
  1. Worked for me using in default profile.
  2. Opened a test profile (without logging out of gmail in default) and got this message:

3. Logged out of gmail in default profile and was able to log in on Test Profile.

Please note: I block scripts and have to disable scripts on both the sign in prompts and once it accepts credentials. Otherwise, get this message.

Just allowing scripts once doesn’t really work. Keeps reloading scripts (looks like same two, if can allow once and click fast enough, will continue).

We have a fix for this issue in the works so when that goes in, the flag can be re-enabled.

1 Like

I tried the above solution. Closed the browser and restarted it. Still get the same error.


I think that is not the flag Mattches asked us to disable.
Its the “Enable First Party Ephemeral Storage”:


Hey, thanks for noting the mistake. I fixed it and now it works

1 Like

This is still an issue.
Thanks to whomever brought up that it is in fact the shields giving GMail issues loading. The issue that is still persistent for me is when I click on my account picture on the right side, it never loads correctly.

I get this error message.
Screen Shot 2022-04-23 at 2.11.25 PM

Me too only since 23-4-2022 . I can’t login to my gmail or my google account generally

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.