Brave preventing MacOS laptop from sleeping

M1 MacBook Pro (MacOS 12.6) won’t enter sleep on battery or charger when certain webpages are open on Brave. I’m not sure which webpages, or what the exact conditions are, but Brave will prevent sleep without any media active.

This has been brought up on the forums before but I haven’t seen a solution.

2 screenshots. One showing that Brave is preventing sleep in Activity Monitor, the other that the media control menu is not active in Brave.

Thanks for the help

CleanShot 2022-09-18 at 21.59.17@2x

Unfortunately, this has been something discussed on chrome, chromium, and other places for a long time. Various workarounds have been suggested, but nothing that I can really recommend. This is typically happening because there is some sort of audio or video that is playing in a tab or window. The reason for that is it is constantly sending a signal to your Mac advising that it’s busy. The purpose is so that it would not go to sleep while you’re watching a movie or listening to music or something.

This is been a known issue on Chromium since at least 2016 and possibly earlier. Brave usually relies on upstream programming which comes from Chromium.

I’m tagging @Mattches and hoping he might have some ideas

@dae,
Do you have any extensions installed in the browser at this time? One of them may be the cause of this — on my end, I see that Brave Browser being open is not preventing sleep on my macOS system:

With all extensions disabled Brave is still preventing sleep. I’m pretty sure it’s due to some website content, but I’m not sure exactly what. I.e. with only wikipedia open, Brave doesn’t prevent sleep. But I haven’t tracked down exactly what website or states cause the behavior. (Again, there’s no media playing or active in the Brave media icon.)

I’ll try to do some more trouble shooting. I take it there isn’t some under-the-hood command I can run to query Brave about what tab is causing the behavior?

Thanks for the help