Why Won't Brave Allow My Computer Screen to Sleep


I set my screen to go to sleep after 15 mins

I expect it to go to sleep, but it won’t

Version 0.69.135
When I open Activity Monitor, and click to the Energy section it shows that Brave is preventing sleep, How do I change this?

cc @Mattches @sriram for assistance here

What OS are you using? Try disabling Continue running background apps when Brave is closed from advance setting and check if it fixes the issue?

1 Like

HI,

  1. I don’t know which advanced settings you are referring to, as I don’t see that option anywhere in the settings page. How do I find it?
  2. Why won’t it let me change the folder I want my downloads to go? I keep changing it to a different folder, but it keeps showing the default downloads one.

Hi,
You can change the location of the Downloads from the Advanced settings in the browser.

Here is a link by Brave, that may help you out too.

By the way, the computer unable to sleep could be due to many parameters namely: extensions, other apps that may be running.

May I know if the computer goes to sleep when the Brave browser is closed?

If yes then

Check browser task bar to see what processes may be running while you encounter the issue.

Hope this helps :v:

Well, I opened my preferences back up, and it now shows the proper folder I want downloads to go to, which yesterday it didn’t… Maybe it took a day for the change to sink in, I don’t know, cause I didn’t reboot the browser, but at least it’s showing the right folder now.

As for why it won’t sleep, I’m stumped. Earlier today it did go to sleep, but just now, I left it open for longer than it should have, since I have it set for sleeping after 15 minutes, and it didn’t go to sleep. And I still get the YES in my Activity Monitor for preventing sleep, and it’s only for the main Brave browser, not any of the “helper” processes, so it’s pretty clear it’s the browser, and not another app.

This topic was automatically closed after 30 days. New replies are no longer allowed.