Brave on Linux doesn't start


Description of the issue:
Brave Browser doesn’t start at all. Using Manjaro Linux with latest updates

How can this issue be reproduced?

  1. Just start the program

Expected result:
Output if program is started in terminal:

$ brave

GPU at BusId 0x8 doesn’t have a supported video decoder
GPU at BusId 0x8 doesn’t have a supported video decoder
GPU at BusId 0x8 doesn’t have a supported video decoder
[6710:6732:1117/134355.643469:ERROR:rewards_service_impl.cc(198)] Failed to read file: /home/andy3153/.config/BraveSoftware/Brave-Browser/Default/ledger_state
[6762:6762:1117/134355.739620:ERROR:ledger_impl.cc(102)] Failed to initialize wallet
GPU at BusId 0x8 doesn’t have a supported video decoder
GPU at BusId 0x8 doesn’t have a supported video decoder
GPU at BusId 0x8 doesn’t have a supported video decoder
[6710:6710:1117/134356.269315:ERROR:CONSOLE(0)] “Unchecked runtime.lastError: Cannot access contents of url “chrome://newtab/”. Extension manifest must request permission to access this host.”, source: chrome-extension://mnojpmjdmbbfmejpflffifhffcmidifd/_generated_background_page.html (0)
GPU at BusId 0x8 doesn’t have a supported video decoder
GPU at BusId 0x8 doesn’t have a supported video decoder
GPU at BusId 0x8 doesn’t have a supported video decoder
[6710:6723:1117/134356.650983:FATAL:gpu_data_manager_impl_private.cc(986)] The display compositor is frequently crashing. Goodbye.
zsh: trace trap (core dumped) brave
✘ andy3153@midnight  ~  [6836] Uncaught exception of type <class ‘gi.repository.GLib.GError’> occured  17/11/19 ~ 13:43:56
File “/usr/bin/chrome-gnome-shell”, line 226, in on_input
self.process_request(request)
File “/usr/bin/chrome-gnome-shell”, line 385, in process_request
‘supports’: supports
File “/usr/bin/chrome-gnome-shell”, line 311, in send_message
stdout.write_chars(struct.pack(b’I’, message_length), MESSAGE_LENGTH_SIZE)
[6836] Exception: g-io-channel-error-quark: Broken pipe (7)

(chrome-gnome-shell:6836): GLib-GIO-CRITICAL **: 13:43:56.973: g_application_release: assertion ‘application->priv->use_count > 0’ failed

Brave Version( check About Brave):
Can’t access it. The browser doesn’t start
My package manager (pacman) says it is brave-1.0.0-1

Additional information:
I am using a laptop, and I’m using only the proprietary NVIDIA drivers, no Bumblebee or Primus