Brave on iPhone 11 Pro - phone gets very hot very quickly

I’ve got a weird thing happening with Brave on an iPhone 11 Pro - the phone gets very hot very quickly after opening & using Brave. As I’m browsing I can feel particular areas of the phone heating up quite noticeably.

Brave is the only app which is causing this. I’ve just upgraded from an iPhone XS, which didn’t have this issue at all when running Brave.

2 Likes

Hi @mstgrv,

Thanks so much for writing in and for reporting your experience. A couple of follow up questions to getter a better sense of what’s going on:

  • Were other apps running at the same time as Brave?
  • Does it happen every time that you open the app?
  • Does it begin to heat up immediately or after you’ve been using the app for a while?

Thanks in advance!

1 Like
  • I guess you could say other apps are open in the sense that I can use ios multitasking to swipe across to other “open” apps, but the way ios multitasking works, those other apps are frozen and aren’t doing anything while Brave is active. The heating only occurs while using Brave, and the heating stops when I either switch to another app, go to the home screen, or force quit Brave.

  • happens every time

  • begins immediately

1 Like

@mstgrv,
Is your iPhone device a part of a Sync chain?

1 Like

Yes it’s part of a sync chain

1 Like

@mstgrv,
Can you try removing it from the Sync chain (temporarily) and see if this makes any difference?

1 Like

Just tried removing from the sync chain - didn’t make a difference, still heats up immediately.

Rejoined the sync chain again - now all my bookmarks are in random order on the phone (they were previously in correct order, and are in correct order on my other devices as well), and the phone is still heating up immediately.

1 Like

Are you using Private Browsing only mode by any chance? Also what theme are you running the browser in Light/Dark?

1 Like

I am using private browsing only mode, I’ll try it with that disabled.

I tried deleting the app & reinstalling from the app store, and then re-adding to the sync chain - that solved the issue with bookmarks being out of order, but the instant heating issue was still there.

Will see if disabling private browsing only mode has any effect.

2 Likes

Still heating up quickly with private browsing only mode disabled.

I fired up the iphone xs I upgraded from to test this on there as well, and I’m actually getting the same thing. I never noticed it on that phone prior to upgrading to the 11, but I’m wondering whether the common factor here might be iOS 13.

1 Like

Quick question what sites are you visiting? Are you playing videos or just normal browsing?

1 Like

Normal browsing - I’ve been testing on news sites mostly

1 Like

I just updated to version 1.12.1 and the issue is still there.

1 Like

Me and my mother got the iPhone 11 pro max and both ours get hot! Never had this problem before. I called Verizon and they took me through steps to try to solve it even doing a factory reset on the phone but nothing worked. Even if I’m just messaging or browsing the web with all other apps closed my phone starts to get warm in seconds and gets hot in just a couple minutes. I’m working on getting a replacement through Verizon because this is just BS. I updated the software today to IOS 13.1, hoping it would solve the problem but NO.

1 Like

My iPhone 11 has been fine and only exhibits an issue with getting very hot very quickly when using Brave. The fact that it also happened on my old iPhone XS as well demonstrates that the issue is not specific to the iPhone 11, but something happening with Brave itself.

I should also say that when using Brave, scrolling on websites is also very glitchy & jerky, so given that the phone also gets very hot very quickly, could there be some kind of issue where the CPU is being maxed out and causing both the heating and the poor / glitchy performance?

No other app I use produces rapid heating or glitchy graphical performance like this.

1 Like

Going to include the devs to have a look at this.
cc; @joel @michal @danishjafri

1 Like

Happy to help fix this in any way I can, let me know

2 Likes

We are looking into this. Do you happen to have sync enabled?
With all of our testing, we were only able to repro this issue for a short window of time during certain syncing operations.

1 Like

Yes syncing is enabled on the phone, but in my testing it still happens when I’ve removed the phone from my sync chain.

1 Like

hi, try turning off “background app refresh”.
if you haven’t, try updating to IOS13.1.2, update Brave for IOS.

1 Like