Brave causing MASSIVE heat output when watching videos in the browser

I was absolutely baffled when I discovered this… When watching videos, brave uses about 10% more CPU than chrome, edge or firefox AND for whatever reason, causes my laptop to heat up to 80 degrees celcius!
FYI, this has never happened on any other browser I used. My laptop is certainly fast enough to watch videos on so I have no idea why this is happening. The heat issue also doesn’t happen with any other browser or application on my laptop. Just brave.
At first I thought it was just some random bug and my laptop just sucks suddenly, but upon running the same videos on edge, i can confirm that brave is the one that is causing issues.
Also, I’ve tested with hardware acceleration on and off, doesn’t affect the result. heats up system either way.

I have the same issue after installing Brave last year on my 2017 MacBook Pro. The phenomenon did not start for quite some time. Then it started randomly causing the CPU to start heating up to 140+ F while watching videos (or not, because it’s random).

I have two guesses for the power usage: 1. I keep a lot of tabs open - four Brave screens worth of tabs! - and perhaps that takes more energy? 2. Apple has been telling me for a while that I’ve run out of iCloud storage space.

Either way, I generally run CleanMyMacX and that quiets things down.

@rs_myst,
Thanks for reaching out to us with this. Hardware Acceleration was certainly my first thought. It could also be a caching issue and/or extension related. Can you try watching a video and, when the high usage/heat starts, go to (in Brave) Menu --> More tools --> Task manager and send me a screenshot of the browser task manager window so we can see what component is causing the uptick in resource usage?

1 Like


This is the task manager of brave upon streaming a video.
Also, this seems to be on the low end, the task manager has shown me worse too. My fans also instantly ramp up…

Try in private mode, no extensions enabled. @rs_myst


In a guest profile with no extensions. I ended all extensions manually as well. Hope it helps.