Metamask Not loading in Brave browser

Metamask is not loading in Brave browser. It is stuck in the loading phase everytime I open the extension. I’ve tried restarting the browser and the laptop. Only other wallet active on the browser is Phantom. Anyone know what the solution is?

@pthind83,
Thank you for reaching out to us.
Can you share a screenshot of what the extension looks like on your end when it gets stuck?

Additionally, what do you have the default Ethereum wallet set to in Settings --> Web3?

Same problem as OP

default wallet set as Extensions

What version of Brave and OS are you experiencing this on? Thanks!

If you press F12 and visit the Console section, do you see any errors when attempting to open Metamask?
image

Using version v1.63.165

The screenshot posted above by another user is exactly what I see. Metamask keeps trying to load and doesn’t prompt for password input.

Here are the errors I get.
Screenshot 2024-03-01 115208

Here is the screenshot and wallet settings on the browser.


Looks like its an issue related to Chromium. What Chromium version are you on?

Metamask extension loading stuck on Version 122.0.6261.6 (Official Build) beta (64-bit)
https://issues.chromium.org/issues/41495590#comment11

Do you know what the fix is?

1.63.165
chromium 122.0.6261.94
Windows 11

image

Hello, I have the same issue with metamask.


and this is how console looks when I want to open metamask

and it seems it never stop. is like a loop of same error.

image

I am using win 11 64bit
image

right click on Metamask and select “Manage extension” >> turn on developer mode (top right)>>Update metamask (Top left).

Worked for me just now.

1 Like

This works - thanks!

1 Like

Didn’t work for me. I also got out of the browser and back in. Still didn’t work. The update seemed to be successful and I got a success message for that but Metamask still hangs with no password prompt.

Does anybody from Brave support read this forum? If not, is there a way to report bugs, like a Jira or BugTrack or something like that?

Tried clearing cache and all cookies for all time after doing the dev mode update and still no luck. Is there any support from Brave for extensions working? If not, should I go back to Chrome for this? I had a pretty complex setup in Metamask and recreating it in another browser is going to be pretty difficult.

Apparently, the version of Metamask got stuck and I can’t get it to update. Is there a way to dump my configs, re-install metamask and the wallet, then import my configs?

Same issue for me, I have updated metamask extention using brave in Lunix Debian and is still keeping in loading state.

promise_resolver.js:84 crbug/1173575, non-JS module files deprecated.
(anonymous) @ promise_resolver.js:84
load_time_data.js:243 crbug/1173575, non-JS module files deprecated.
(anonymous) @ load_time_data.js:243
util.js:320 crbug/1173575, non-JS module files deprecated.
(anonymous) @ util.js:320
brave_new_tab.bundle.js:2829 setting today viewport observer, should only happen once

Debian version:
cat /etc/os-release
PRETTY_NAME=“Debian GNU/Linux 10 (buster)”
NAME=“Debian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=debian
HOME_URL=“https://www.debian.org/
SUPPORT_URL=“https://www.debian.org/support
BUG_REPORT_URL=“https://bugs.debian.org/

Brave VERSION

Version 1.26.77 Chromium: 91.0.4472.164 (Official Build) (64-bit)
(https://brave.com/latest/)

MetaMask version - 11.13.1
An Ethereum Wallet in your Browser

Hi Guys, I solved this issue by installing latest brave version and my wallet was still there I did not have to import it.