Brave not displaying the cookie confirmation makes the screen unusable

Summary: When viewing a site that requires storing a cookie, Brave mobile is preventing display of the notification even when cookies have been allowed, shields are off, etc.

Brave mobile: 1.58.135, Chromium 117.0.5938.140
OS: Android 12; Build/SP1A.210812.016
Device: Samsung S10+

Details: This site ( requests first-time users to “select a location” which is stored in a cookie. When first going to the site, it displays the “select a location” and about two seconds later displays a “cookie” notification. But this doesn’t happen on Brave mobile. It does appear correctly as expected on Edge mobile and Firefox mobile. On Brave mobile, instead of displaying the cookie notification, at the two-second mark, a shadow is placed over the entire screen and no user input is recognized or accepted; i.e., the screen is now locked. Despite enabling cookies for this site, enabling cookies for all sites, disabling the shield, everything I could think of, it continued to exhibit this behavior.

Note that the site allows the user to bypass the notification and not make a selection by tapping elsewhere on the screen. Taking this option will result in the site behaving always as if the user had never visited; i.e., is a first-time visit. Again, this works correctly under Edge mobile and Firefox mobile but does not on Brave mobile.

[NOTE: I tried to upload all the images but it is still considering me a “new user” :frowning:. I can provide more the rest upon request.

Brave initial page

Brave “shadow”

Edge cookie notification

Firebox cookie notification

UPDATE: I tried the solution found in this post Jio Cinema Block Brave but I wasn’t able to add it in the mobile app because it does not display any [Save changes] button in order to apply the change. The button does appear in the web browser version so I added the “fix” there and confirmed it now appears in that box in the mobile app version. But it did not fix the issue.

Brave mobile app page:

Brave web browser page:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.