Bug/Glitch Block cookie menu

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

If choose Block cross-site cookies and tap Done show as Allow all cookies.

https://streamable.com/yhxohd

and check on brave shield the rules same allow all cookies.

https://streamable.com/cq1gps

How can this issue be reproduced?

  1. Open Brave shield & privacy
  2. open Block cookie menu
  3. choose Block cross-site cookies and tap done

Expected result:

show as Block cross-site cookies and brave shield rules follow the rule

Brave Version( check About Brave):
Brave 1.50.114, Chromium 112.0.5615.49

Mobile Device details
Android version 13 , Phone

Additional Information:

i already comment this issues on github at same issues
https://github.com/brave/brave-browser/issues/29718 .

1 Like

Any news when this bug will be resolved?

Still present on Android Brave Beta v1.52.84.

Workaround for now, clear brave data via mobile device settings (before it make sure sync on and toggle “Settings” off so you can recovery old data) after clear data open brave like normal and setting what you like but remember don’t do anything at cookie menu or you need do this again.

There’s an workaround for this, instead of going to ‘Brave Shields & privacy’: Go to ‘Site settings’ → ‘Cookies’ and choose ‘Block third-party cookies’.