Brave Metamask Wallet Issue


I’m using the Brave browser Metamask built-in wallet and I’m trying to send an ERC20 token from my Metamask ETH wallet to Binance ETH wallet address but I’m always getting this error message.

[ethjs-query] while formatting outputs from RPC '{“value”:{“code”:-32603,“message”:“Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32602,“message”:“transaction could not be decoded: unsigned transactions not supported”}}’”}}'

and on etherscan it says

Oops! An invalid Txn hash has been entered: undefined

I have enough ETH to pay for the gas fee and I even try to increase the gas limit but I don’t find any luck transferring the funds. Hope you can help me with this one. Thank you

Kind regards,


Same problem here. I have been wasting my whole day troubleshooting this!

I cannot make any transactions on ETH, BSC, and Polygon networks… This is costing me a lot of money. When can we expect a fix?


Same on my end. Kinda frustrates me quite a bit.


Since it’s the weekend, I’m guessing this is going to be broken all weekend.

:wave: bye to all my profits I wanted to take.

When the hell is software companies going to learn, DON"T DO UPDATES ON A FRIDAY!!!


I too am losing money because of this. Not fixed soon, I’ll calling my lawyer!


Ya I have the same problem on Uniswap. Everything was fine, wasn’t doing anything crazy and then this just started happening. Now I can’t get any transaction to work on any chain L1 Eth L2 Matic. nothing, get same error on everything. Been debugging this trying different things for over 8 hours.

Swap failed: Unknown error: “Error: [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32602,“message”:“transaction could not be decoded: unsigned transactions not supported”}}’”.


I am having the same problem. this happened once before And cannot remember how or if I fixed it. I think i ended up switching to a different wallet. but this is my main wallet known by all my apps. did this is driving me crazy. did you fins a solution?


Same here! No transaction are possible since the update! How can you reasle the update without a proper testing!!! what a mess!!!

Hi all, please see Brave crypto wallet error after latest update - #51 by onyb.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.