Brave crypto wallet error after latest update

Hey onyb, while we wait for an official fix, can you confirm if it’s ok to try with spielcrypto’s workaround?

I got a coin launch in 3 hours that I really need to do stuff with so I’ve got half a mind to try that.
Cheers!

I have a 24 word legacy seed too

Man, this works for me! Thank you for sharing…

1 Like

Thank you so much. The work around solution is works for me. Following suggested steps, I used the new metamask with 12 seeds phrase, then restoring the wallet on brave wallet with this new phrase, and finally importing the private keys from my prior wallet. To get all the assets just opening etherscan, find the contract one by one from CG, then adding it as a custom tokens. Wallah everything back to normal. I can do transaction now.

Again Thanks Mate. Happy Weekend from Jakarta!

1 Like

12 word seed from years ago and prior to using on Brave.

So we are conclusive that the keyring that handles legacy seeds generated on or before Brave Browser v1.0.26 is broken in the latest release. An overwhelming majority of you here are using this keyring, hence the errors.

This also means all other keyrings (Ledger, Trezor, Simple HD keyring) are NOT impacted. If you are in this category and still having issues, it’s probably due to an unrelated reason. I’ll be happy to follow up on that separately.

Kudos to @spielcrypto for finding a temporary workaround, however we don’t recommend doing that for security reasons as it exposes your key material in a form that encourages copying to clipboard (beware of clipboard hijackers!). If you’ve already used this workaround, I suggest going for what I’ve suggested below.

Recommended workaround

  1. Download the Crypto Wallet v0.1.97 package from the official releases here. Click on ethereum-remote-client-brave-0.1.97.zip under Assets (direct link here). Verify that this comment is posted by a Brave staff. :slight_smile:
  2. Extract the archive to a directory on your machine.
  3. Click on Menu > Create a New Profile.
  4. Use whatever name you like for the profile: ex, Crypto Wallet v0.1.97. Click on Done. This will open a new window with a fresh profile that doesn’t pollute your regular browser settings.
  5. Click on Menu > Extensions.
  6. Enable Developer mode toggle. You’ll find it at the top-right corner.
  7. Click on Load unpacked.
  8. Select the directory of the downloaded package in step 2. This should add “Crypto Wallets” to the extensions.
  9. Go to Crypto Wallets (brave://wallet).
  10. Restore your 24-word mnemonic.
  11. Grab some beers, because you’re good to go!

Once a real fix is shipped (ETA is Monday), you’re free to delete this profile and continue using Crypto Wallet like nothing happened.

2 Likes

This work around worked for me! Thanks man.

Thanks man! In the near future, do you recommend we migrate our legacy seeds somehow to avoid further issues?

It’s desirable, but it’ll involve an on-chain transaction. It’s important to have a 24-word mnemonic that’s compatible with all crypto wallets to avoid vendor lock-in with Brave. This doesn’t mean your current seed is in any way less secure than the newer format.

If you’re not sure how to do it in a safe manner, we can write a detailed step-by-step guide for you and others to follow. For now, the suggested workaround is safe to try and will unblock most of you here until a proper fix is available.

Cool beans, thanks! Btw I confirm that the workaround worked for me as well.

1 Like

Thanks for confirming. Hope the coin launch was good. :slight_smile:

will there be a fix on Monday for the ‘invalid sender’ error aswell? - RPC ‘{“value”:{“code”:-32603,“message”:“Internal JSON-RPC error.”,“data”:{“code”:-32000,“message”:“invalid sender”}}}’

I get this when trying to send funds/interact with defi

2 Likes

I’m using MM with a ledger nano x that has a 24 seed.

Not sure how to get the code for the error but basically getting this: Warning! Error encountered during contract execution [ Reverted ]

Thanks onyb. I have the same issues described here with a 24 word phrase using
Brave v 1.29.79

Thanks onyb. rather than try the work around I will wait on your Mon fix. cheers

No, it’s not that simple, sorry. Now I have to re-add all the custom networks and currencies I need to use. Also have to setup extensions I need on this new profile.

Why wouldn’t a patch be push ASAP? Monday is unacceptable IMO. Not like this is some small issue. This has cost myself and I’m sure MANY others a lot of money and time. Image all the users that haven’t found this thread!

I have been a Software Engineer for over 10 years and my guess that it’s the weekend so that’s why we all have to wait until Monday. This is why the companies I have worked for push updates out at the beginning of the week and NEVER on a Friday.

I am now in crypto full-time and this bug has really cost me and others I know that didn’t even bother posting on this thread because they knew I was on it. We are upset about this and I’ve been using Brave a few years now but I’m going to reconsider using it after this mess.

Thanks.

14 Likes

totally agree… i have over 5 networks to manually add plus import all tokens… pure madness

4 Likes

+1 well said b3nelly!

3 Likes

Missed out on an NFT sale I had planned to jump on. It has since gone 5x. Opportunity cost is around $2k. I am a big Brave fan, but this hurts - please crank on the fix Brave Devs, thanks.

8 Likes

yes down last 24hrs, cant do a thing, have a 12 word phase, rathera fix then a work around solution pls.

4 Likes