Brave loads Facebook really slowly


Brave is loading Facebook really slowly since a while now. I didn’t notice it earlier because I rarely use FB, so I don’t know since when it is happening.

It loads instantly in Firefox and Chrome. So, it is not my internet.

Here are the things I have tried-

  1. Did a fresh installation of Brave.
  2. Tried disabling Shield. Changing it to Normal and Aggressive.
  3. Tried disabling fingerprinting.
  4. Tried Brave Nightly and Beta. Tested them without configuring anything.
  5. Tried using secure DNS in browser from Google, Cloudflare and ControlD.
  6. Tried using custom DNS in Android. Also tried changing DNS in my router.
  7. Tried on my brother’s phone as well. Same issue.
  8. Tried using VPN.
  9. Tried using different FB accounts.
  10. Tried using different ISPs.

Tested on realme GT Neo 3T & IQOO 7. Both running official Android 13.

There was also someone who posted similar issue on Reddit and it is exactly like that-

Hello @Saoiray , do you have any idea about it? Or can you can tag any dev who you think can help me regarding this? I have tried to be as detailed as possible with all the workarounds I have tried.

Nah, no clue. I was hoping to figure something out while playing around with my device, but having the same issue. So when first visiting Facebook, it takes about 5 seconds to load. Prior to that you’d think Block Scripts was active or something. And like you said, it doesn’t matter if Shields is on or off, it loads the same. And happens both on Nightly and on Release versions.

I’ll tag in @fanboynz and @Mattches to see if they have any ideas.

What is interesting is this issue does not occur on my iPhone or on Desktop.

1 Like

Taking a look now — I don’t personally have a Facebook so I’m asking someone on the team to test for me :sweat_smile:

1 Like

Can you actually tell me roughly how long it takes to load? Are we talking about ~5s or much longer than that?

Yes, it takes about five seconds or so. Usually less than ten seconds. Meanwhile on other browsers, it loads instantly. You can check the video on the Reddit link I mentioned in my post for reference. It is exactly same in my case.

I have tried disabling all kinds of stuff and still ending up with this.

Yes, I don’t have this issue on my iPhone and Windows PC either.

By the way, a friend of mine is not having this issue. He didn’t setup anything in Brave either and he got a mid-range phone - POCO M2 Pro. So, doesn’t seem to be performance related. He is still on Android 11 while I tested on A13, so that could be the reason. :thinking:

We now have an issue opened for this:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.