Brave keep crashing loading one specific URL but only since today


Description of the issue:
I have created a plugin on spigot, the popular minecraft plugin website and server core.
I visit my plugin page often, that’s why I know it crashes only since today.
I tried visiting other plugin pages, to see if it comes from the website itself or from brave.

I think the issue comes somewhere from caching/datastore, because other plugin pages are working correctly.

What appens is: just after the complete loading of the page, brave crashes.
https://www.spigotmc.org/resources/lootchest.61564/

How can this issue be reproduced?

  1. Personnaly, I just go to the page and crash. But if my bet is good and that it comes from user datas, it may not crash on other people’s phone.

Expected result:
Well… stay on page after load

Brave Version( check About Brave):
1.52.130

Mobile Device details
LineageOS, android 13, xiaomi mi 11i (haydn), 8go ram, 256go, snapdragon 888

Additional Information:
I tried to delete spigot cookies by clicking on the locker, it didn’t solve the issue.
I tried cleaning my cache datas as well.
I WILL NOT erase my brave datas/my phone of uninstall/reinstall brave just for testing purpose, sorry
I just want to warn that the issue exist

I cannot open the crashes page because dev_ui is not installed. I installed brave with Aurora store, and some people thinks it comes from here. My problem could also be related to this, who knows…

@Black_Eyes72,
The issue might be the fact that the version of the browser you’re using is several updates behind. Android is currently on v1.64.113 — I understand that you don’t want to uninstall but it is hard to diagnose issues with devices that are running such outdated versions.

I was able to visit the link you shared on Android without any issue. If you’ve already cleared site data and your cache and the issue is still present then there isn’t much else to do here. Especially with such an outdated version and no way to submit crash reports.

I would recommend testing the site and with Shields disabled to see if this makes any difference.

It might have something to do with a youtube video embed
image
It’s LIKELY, but not guaranteed to be related to the current known issue