Brave is now preventing adding custom search engines

Brave is now disabling the ability to add other search engines, really slimy behavior by the developers, shame on them.

My setup:

Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (64-bit)

Ubuntu 22.04

Two methods to add it suggested by others on the forums (not intuitive, once again brave is being underhanded and using dark patterns to prevent this). Presearch will not show up on either method.

Method#1

If Presearch support open-search, then you can add it yourself (it’ll listed under “Recent visited” under Settings > Search Engine).

Method#2

1 - Go to this link https://engine.presearch.org/
(Login if it’s shows you not logged in because i was already logged in but at that link it showed i wasn’t).

2 - Type anything in the search box

3 - when the results page shows up… just go to brave browser settings and hit search engine

4 - Once in search engine, select standard tab (and private tab after if you want), at the >bottom you will see presearch listed (as used for a recent search). And then just select it >and now you can use it as your default search engine for any search on your mobile >browser.

In addition, the builtin ability to use a shortcut to search any site does not work either

Settings → Search engines → manage search engines → add
Added as Presearch, shortcut :p, https://engine.presearch.com

Default shortcuts work fine, this does not.

Im switching to firefox if they do not fix this now. I dont need to be told i have to use a handful of compromised search engines.

@presearchuser you’re doing it wrong. You don’t put in the website only. You have to do a search on it and then replace your search term with %s

So it would be: (I’m creating more steps than it really is, probably should combine some of these, but it is what it is)

Step 1. Go to https://presearch.com/

Step 2 Search an item. Let’s pretend it’s Aliens.

Step 3 Look at Search/URL bar. It will now say https://presearch.com/search?q=Aliens

Step 4 Replace Aliens with %s to end up with
https://presearch.com/search?q=%s and then copy/cut it

Step 5 Go to brave://settings/searchEngines

Step 6 Add under Site search

Step 7 Fill out the form to look like this, where you put in https://presearch.com/search?q=%s under URL part :
Settings - Manage search engines and site search - Brave 9_20_2022 3_52_47 PM

Now it’s programmed in. Just typing :p followed by a space will switch to Presearch. If you want to make Presearch your default, then…

So hamburger menu while in there, hit Make Default, and there you go, it will always search Presearch by default.

1 Like

Also, I’ll have to tell you that I have Index other search engines Automatically indexes websites that follow the OpenSearch spec. enabled at brave://settings/search

As a result, it already had placed Presearch into my search engines. So I didn’t even have to do the steps in the prior. Not sure if you have that enabled or disabled. Mine came disabled by default and I had to turn it on.

Now, when Presearch was added, it was stored under inactive, just as you can see in the screenshot below:

So I had to click Activate and then it appeared in options above. When I clicked to Edit it (the pencil icon), the default Shortcut wasn’t :p but was instead engine.presearch.com (which really isn’t a shortcut). So I had to edit that for :p to work. Saved it and everything worked perfectly.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.