Brave is making me pull my hair out!

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Erratic behaviour:
Happens when browsing most sites

approximately last 6 or seven updates

I am have been using Brave on Linux ( Debian branch ‘‘beowulf’’)
It was working fine , up until the lastT 3-6 months.
I noticed strange crashes , things like tabs not opening, not being able to type in searches.
The behaviour got stranger and stranger with each Brave update.
The latest one will not let me scroll through bookmarks, and also crashes when I maximise a YOUTUBE video?
I found in order tp get any stable version I had to roll back some 6 or 7 versions ??

Is anyone else experiencing this - it’s really is driving me mad :slight_smile: - in fact I am now reluctantly using Firefox as my daily browser!

Many Thanks

1 Like

YOu should not roll back that many (or any) browser releases as each update contains very important security fixes.

Were you (before rolling back) using the latest version (v1.17.75 at the time of writing this)?


thanks for the reply.

yep, i was on the latest.

you,re right security is compromised, but the earlier versions are much more useable. i really mean- MUCH more :slight_smile:

firefox works fine - but slow!

thanks again


While I understand your position, there’s not much we can do for you at this point without more information about the issues and the conditions needed to reproduce them.

First of all, I want to make sure that you are using our official packages. Did you follow the installation instructions on

If that’s the case, I would suggest you check that the brave://flags/#ignore-gpu-blocklist option is Disabled (copy that URL into the address bar).


Thanks for the reply.

What do you need exactly? :slight_smile:



I use the synaptic package manager with Devuan ( debian variant)

It keeps up to date Brave.

My Linux installation is updated frequently

I know this is a long shot, but Devuan is ‘non- system d’ ?



Good, so you’re using the official packages, not the Snap.

I doubt this would have anything to do with systemd. It’s more likely to have to do with video drivers. I would suggest going into brave://settings/system and turning off hardware acceleration:

1 Like

This worked - thank you!

Appreciate your advice.

I am now curious why the video drivers are not working correctly for my build?


It’s pretty hard to know. Many video drivers are notorious for being buggy and it turns out that browers exercise them quite a bit.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.