Brave is running like a dog since several versions on linux


Description of the issue: Laggy start , opening a window or new tab spikes the cpu. Initial launch takes 30sec because the new tab is lagging.
How can this issue be reproduced? as above

Expected result:

Brave Version( check About Brave): latest stable linux debian build but been present since at least 4 versions

Additional Information:

1 Like

@leifrod,
What troubleshooting steps have you tried?

  • Try Creating a new profile (Menu --> Create new profile) and see if browser performance improves.
  • Have you tried clearing browsing/cache data?
  • Do you have any extensions installed at this time? Can you try disabling them and see if performance improves?

New profile helped but wallet restored and no BAT!! I had 54!

When I open the old profile it’s gone as well !! WT??

Not to mention that I’ve lost 100 BAT withdrawing to uphold

What’s going on?

So the new profile and clearing stuff helped only for the first 2 days, Brave went back to old lagging start now again.
My 59 BAT was synced in the end to the wallet, took some hours.
The 100 missing BAT is still an issue.

Was using Brave on MX Linux and it worked flawlessly.
No lagging.

BAT is an issue.
Mine didn’t come back on Windows until after a system reboot.
Brave must resolve such issues.

i am using brave on centos 8 and it work fine unless if i hibernate the system while brave is open then when i start the system the whole system become unusable so i just close brave before hibernate

please remmber that there an option that let brave work in the background when you close it
so check settings - additional settings - system

Continue running background apps when Brave is closed turn this off

even if you do not hibernate try to close it also and see how things is going

for bat i agree that a common issue related to it

hope that help and have a nice day :slight_smile:

Hi

I close brave all the time and reopen. It does not run in the background.
Issue is somewhere with the profile since it works ok on clean profile but after some time crapps out.

hope someone of the team help you and have a nice day :slight_smile:

how version libgl1-mesa-dri ur install?

i last update this lib also get some freez, recovery on old version and nice.

Both on AMD lappy GPU running mesa and on desktop running NVIDIA on latest 410 driver it runs awfully. It’s something in the code around rendering or something. GPU process is jumping with the CPU as well.

yes latest driver version 20.0.4.1 no good. u need install manually 20.0.4-2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.