Brave Browser crashes out of nowhere and bricks the operating system (Linux Pop_OS! 21.04)

Good night, this message is to inform this problem I’m having with the current version of Brave Browser.

Description of the issue: After some time surfing the Internet with Brave, the program crashes and automatically sends me with the “Force Stop/Wait” prompt. After the second time, the OS bricks and I have to hard reset it.
How can this issue be reproduced? Using the Program
Expected result: Crashes after some time, bricks the OS.

Brave Version( check About Brave): Versión 1.32.113 Chromium: 96.0.4664.45

Additional Information: None

good night @josuevargas

how did you installed brave ?

not sure the following would help but you can try it if you like

  1. try to use brave in private mode and see if it work fine there or not
  2. if it work fine then try to disable all extension and see if it work if yes then the issue with one of your extnesion try to enable them one by one till you get the cause of the issue
  3. if the extension is not the cause then try to clear the cache / history the longer would be better
  4. if those does not help then try to create new profile and use it and see if it work fine on that new one

hope that help and have a nice day :slight_smile:

Hey, this is also happening to me on Fedora. Using the official Brave repos with no extensions installed.
OP, are you on Wayland by chance? Idr if POP_OS uses wayland by default.

Brave was working fine until the 1.32 update.
1.32 launches, however it immediately locks up, nothing is clickable except the settings menu which opens to a blank gray panel.

Hello @mikeymop

Pop!_OS uses Xorg it’s

i use wayland on rocky linux (1:1 binary compatible with RHEL) i do not have this issue

did you tried the above suggestion

hope that help and have a nice day :slight_smile:

Good night,

I checked out what was the problem. It was the Pop!_OS kernel. Due to some stuff, the kernel has problems. I only changed to the previous kernel and problem solved.

Thanks for all. Consider this as a solved issue.


you very welcome and glad to know you figure it out

Hello @josuevargas do you recall which kernel version was problematic?
Was it of 5.15.x?

@justsomeone1 The above suggestions did not work for me.
I also tried the other suggestions I saw on the forums such as erasing the cffkpbalmllkdoenhmdmpbkajipdjfam directory with no luck.

just to make sure that you tried to create new profile and it fail right?

I was not able to create a new profile because the browser crashed immediately.
I was able to resolve this by running
brave-browser --args --disable-gpu
Then opening brave:flags and resetting all of my overrides.

Once relaunched, I was able to slowly tick on more gpu flags at least granting me back hardware accelerated 2d canvas.

start brave with this argument --user-data-dir
for some details about it check this one

it will start brave as if it new profile then from there you could create new profile then close brave and start it normally
(do not delete the old one or you would loose any data there)

Yes, 5.15.x. I changes to 5.13.x and the problem was solved.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.