Brave injects random text when copying page contents


Description of the issue:

When copying text from raw content such as that displayed by Github’s “raw” link, Brave inserts text at the bottom that does not exist in the file.

How can this issue be reproduced?

  1. Browse to https://raw.githubusercontent.com/microsoft/windows-container-tools/master/LogMonitor/src/LogMonitor/sample-config-files/IIS/LogMonitorConfig.json
  2. Use Cmd-A,Cmd+C to select all the text on the page and copy it to the clipboard.
  3. Open any text editor and use Cmd-V to paste the buffer to a new file.
  4. Note the last line of pasted text {"mode":"full","isActive":false}.
  5. Note that the last line of pasted text does not exist in the original content.

Expected result:

The exact contents of the raw page should be copied to the text editor window.

Brave Version( check About Brave):

Version 1.26.77 Chromium: 91.0.4472.164 (Official Build) (x86_64)

Additional Information:

I’ve reproduced this issue with multiple text editors including Atom and Visual Studio Code. If I use View Source to display the page content, the copy operation works as expected.

Couldn’t reproduce the issue using Notepad++. Can you please test in a private window with all extensions disabled?

Thanks so much for the quick response. As you suspected, it works fine in a private window with all plug-ins disabled.

I’ve identified the culprit as the Grammarly For Chrome plugin version 14.1022.0.

3 Likes

I should also mention that I do not see the same issue in Chrome with the plug-in enabled. So I’m still not sure of the true culprit.

1 Like

I just installed https://chrome.google.com/webstore/detail/grammarly-for-chrome/kbfnbcaeplbcioakkpcpgfkobkghlhen in my user profile I use for testing purpose. I confirm I could reproduce your issue.

I don’t know the reason for Grammarly’s behavior in Brave, I can only recommend reporting the issue to Grammarly’s developers so they can take a look and commit a fix if needed.

P.S If you select the text manually (avoid Ctrl + A), the extra line isn’t added.