In some tabs, ⌘ + C is Copying a Clean link of the page, not copying selected text


In some of my tabs, when I select text and press ⌘ + C as usual to copy some selected text, the browser is actually copying a clean link, instead of copying the text…
This is also reflected in the top menu:

What causes this, so I can prevent it in the future, and how do I turn it off?



Is this happening with arbitrary text, or only text that is effectively a URL?

Arbitrary text. It seems to be linked to certain tabs I have open…

Really weird, I can’t even reproduce the issue it. In a different tab, same window, there’s no such behavior. Maybe just some hickup, but would’ve liked to have understood what could’ve triggered it.


OMG thank you! I thought I was taking crazy pills!

I even tried creating a new Keyboard Shortcut specific to the Brave Browser for Copy Clean Link like Command+Opt+C (so Command+C gets restored back to normal Copy), but that did not work.

1 Like

I opened a github issue for this I hope they fix it


I pinged few PRs that got merged in that might be related, not sure why they made a global change for something that is industry standard keyboard shortcut and thought it was a good idea to release. This is a big regression


I am having the same issue, it’s driving me absolutely insane.
Is there a solution yet :melting_face: ?


This was driving me nuts. I’m now using a different browser until they fix.


Y’all can just look at the GitHub link above to see the status.


Hi. Having the same issue.

I select any text on a page and Command+C does a clean copy of the URL. Very frustrating. The only way around it is to go to the top menu > Edit > Copy.

The reason it was probably overlooked is that it does not happen on all websites. I can tell you it happens on &

I solved this by restarting the browser. It worked for me.

1 Like

Hi :wave: Same here.
I believe it started when I accidentaly chose “copy clean url” on a right click on a link.
The browser works fine for about 2 to 3 hours and after that, the CMD+C is a mess.

Half solution: reboot the browser like @runmankhan said, OR use the right clic to copy the text (and NOT use the keyboard).

This is infuriating, it keeps coming back whether I restart the browser or not. It keeps happening, so far the AWS Console seems to be the biggest culprit.

How come this wasn’t fixed yet?

It’s really annoying.

Also having this same issue!! It’s really frustrating, there’s no way to predict when it’ll pop up, sometimes even within the same page.
It first started a couple days ago, after I had to restart my computer - really wish I hadn’t had to do that because the restart must’ve updated my Brave browser, and now it’s non stop.
I first noticed it while working in Google Docs, found this threat (and thankfully someone in this thread pointed out the “Copy clean link” command in the browser. I thought I was going crazy). It’s inconsistent, because even in a separate Google Doc - the SAME website/platform - the “Copy clean link” option isn’t even there. It’s especially frustrating because it frequently pops up in Google Sheets where I have to copy formulas repeatedly and I can no longer work at a normal pace, having to right-click cells and select “Copy” in the pop up bar.

I have no idea when it started and how but I am going completely bonkers and about to ditch brave altogether unless they fix this.

Have the same issue. After first copy and paste it works as it should. hope they will fix this soon.

Maybe fixed? Release Channel 1.49.132

1 Like
1 Like

Still having this issue.
Looks like it wasn’t fixed