Brave forcing HDR YouTube, how do you turn this off?

Installed Brave today but when I go to YouTube all the videos are terrible looking with no white detail (screenshots provided) the only playback quality options are all HDR and I do not have an HDR screen. Can’t find anything in the settings for Brave and HDR or in the Flags for HDR.
Referring to videos that I guess are uploaded in HDR.
4K HDR video on YouTube

Why does Brave suggest I have an HDR screen?
Is no one else having this problem?
How do you turn this off?

Does not happen on Firefox, Chrome or Safari

Brave Version 1.19.86 Chromium: 88.0.4324.96 (Official Build) (x86_64) All settings are original defaults.

MacOS Big Sur version 11.1 iMac (Retina 5K, 27-inch, Late 2015) Processor 3.2 GHz Quad-Core Intel Core i5 Memory 32 GB 1600 MHz DDR3 Graphics AMD Radeon R9 M380 2 GB

Brave is the first image and Safari is the second


1 Like

@Code_Quad,
I truly have no idea – I’ve never seen this before. Can you try clearing cache/browsing data for youtube (lock icon in address bar then Site settings --> Clear data) and see if you get the same results?

1 Like

Hey Mattches, yeah I can’t understand why either. It’s a weird one, but I tried clearing the data the way you instructed but it didn’t fix it.

2 Likes

@Code_Quad,
Can you try creating a temp profile, visiting Youtube and see if you get the same results?

I’m having the same issue. I tried creating a new profile, but same result.

Version 1.19.86 Chromium: 88.0.4324.96 (Official Build) (x86_64)
MacOS Catalina 10.15.7
MBP16 inch Core i7 2.6Ghz 16GB RAM AMD Radeon 5500M 8GB

Thanks for your help

1 Like

Hey Mattches,
Problem still persists after Creating a temp profile, and with logging into youtube.

First screenshot is logged in to YouTube.
Second screenshot is using a temporary profile.


2 Likes

Just a hunch, but, could this be related to a change in Chromium?

Today I got the same problem (see image). (I have a Macbook Air 2020 M1, in Safari the same video is looking fine). Thanks for any suggestions.

1 Like

FWIW, I think my Brave updated because the icon now has a white box around it and the problem is no longer happening :man_shrugging:

2 Likes

What version do you have?
I updated yesterday but I’m still having the HDR problems.

1 Like

Interesting. We have the same version.

I haven’t updated my OS either. Sorry I can’t be of more help.

2 Likes

Oh no problem that’s the joy of technology.
I do hope that there’s a solution soon though.