Brave Firewall 7 VPN session expired

Windows 10 - up to date (all drivers and OS)

Good Morning, clicked on VPN had to sign in, signed in refreshed VPN and now when I click on the VPN button all I receive is ‘session expired please log in to your Brave Account to refresh your VPN’ and no way to start the VPN.


I have just logged the exact same issue. Watching this thread for a response from the brave support team

1 Like

If you can, please submit a ticket here so we can see all of the relevant account information - . Thank you!

1 Like

Hi @steeven I have logged a ticket like I mentioned in the comments. The subject line of my ticket logged today is " Request Received: Unable to connect to VPN due to session ended issue inspite of signing in again and refreshing vpn in plan"

@steeven Inspite of logging into the brave browser and “refreshing VPN” in the Plan, relaunching the browser - the error message still remains

the same as in the attachment.
System - Windows 11

Thanks @anonymizer - what happens when you click on ‘Login to your Brave Account’?

@steeven After I login to the brave account - click on VPN Plan - Refresh the VPN - and try to connect to VPN again - The same error message appears and doesn’t allow me to enable VPN connection as the VPN button does not move

Thanks @anonymizer, following up in a DM.

thank you for responding to the issue on priority @steeven Issue resolved, much appreciate your help!

@steeven Hallo, the problem went away for 24+ hours and has reared its ugly head again. I have the same issue as before. I sign into Brave account, click onto the ‘Refresh Brave VPN’ and nothing happens, the ‘Session Expired’ message is still on the VPN switch/button.
Thank you for your time.

@steeven Hello, may I know how to resolve this issue as well?

1 Like

Hi all, can you confirm that this is still an issue for you? I’m seeing several reports that it’s resolved and others that it has not. Thank you.

its still occurring for me

I’ve been having this issue for a couple of days now… sucks because I’m paying monthly for this and haven’t been able to use the VPN for 2 days now.

@ToothFaerie @anonymizer @Shhocker
Hello all,
My apologies for this issue you are all running into. It sounds like the subscriber credentials are not being properly generated when you try to connect which is what validates your subscription and allows the connection. To try to reset this, please do the following:

  1. Open Brave and navigate to brave://skus-internals/

  2. Click Reset SKUs state

  3. Login to again and if needed click Refresh Brave VPN and try to connect.

1 Like

That worked… thanks!

Good morning, thank you for your reply. I will keep this process and hopefully not need to use it. The VPN started working again later that day, sometime at night. I have to say it is rather annoying that it only seems to affect my Main PC (the one I purchased Brave VPN from). I have checked all security features, all my drivers are upto date and I do not have processes that are unnecessarily taking up cycle time. The other two PCs, that are not really kept to the same standard of maintenance, were working fine, then again they do not use the VPN function as much as I do myself as they are usually playing games or watching rubbish on Tubeyou.

Have a great day.

I’ve got the same problem but can’t file support ticket because I can’t find the invoice number

Please see the DM I just sent you for information on how to submit.

For everyone else here — please try the following steps below to resolve this issue.

Some users have had success simply using the Reset SKUs state button, which you can do by:

  1. Launching Brave and going to brave://skus-internals
  2. At the top, click the Reset SKUs state button
  3. Close and relaunch the browser
  4. Log back into, click Refresh Brave VPN and test again to see if the VPN is now working

If the above did not work for you, we’ll need a bit more information from you to resolve he issue. Can you please provide the following:

  1. Launch Brave and go to brave://skus-internals
  2. Click Fetch SKUs state
  3. Please copy any out put that appears — note that if the text is too long, you can paste into a word document instead
  4. Please submit a ticket to us here and be sure to:
    • Make the subject line “Refresh VPN/Session expired issue”
    • Include all the requested information on the form
    • Include the SKUs internals information you copied or saved to a word doc (if data was saved, you can upload it as an attachment)

Note that there is no personally identifiable information contained within the SKUs internals output. Further, this information will go a long way towards helping our team find and fix the root of the issue.

Thank you

1 Like

Hi Shznakl,

This does temporarily fix the issue, but I am now required to follow these steps everytime to access VPN which is tedious and unnecessary. Is there a permanent fix being rolled out any time soon ? How long do we have to continue doing this to be able to connect to brave VPN?

1 Like