Brave doesn't let me verify my wallet

I have completed Uphold’s KYC process, and I have managed to connect the Brave browser of one of my computers to my Uphold account. Yet, on my principal computer, the Brave wallet interface just doesn’t give me the possibility to verify my wallet.
Where the “Verify my wallet” button is supposed to be, there only is a non-clickable text saying “Your balance”. Please help me making this button appear.

1 Like

@Ennambhor,
Can you tell me what OS you’re using (your princiapl PC), as well as what Brave version you’re using?

I am using Windows 10, with Brave 1.9.72 on both of my computers.

@Ennambhor,
Can you first try updating again to the latest – version 1.9.76. Then, if you’re still seeing this issue, can you share a screenshot of your Rewards panel, as well as your Rewards Settings page (Settings --> Brave Rewards)?

I do not have access to my computer right now, but I got a few screenshots. Is that what you want to see ?

1 Like

Seems like you have the Japanese version of Brave @Ennambhor . See that it shows BAT Points (BAP) instead of BAT.

Now that is some stunning news. I don’t event know how I could have downloaded the Japanese version.
Could you send me a link to download the European version of Brave ? So I don’t download the wrong version again

Hey there, it’s me again

I downloaded the last version (1.9.76) but it still displays the same thing. I don’t know if I downloaded (i don’t know how) the Japanese version again, but I still have BAT Points instead of BAT, and no “Verify your wallet” button. Any other idea to fix this ?

it’s only five dollars buddy it’s not worth it. I believe that you will succeed soon in this life, be happy and thank you for being. :100: