No Option to Verify Wallet on Windows 10 - Version 1.5.122

I recently moved to a new PC, downloaded Brave, and restored my wallet from the old PC. My Uphold wallet is verified and was done on the old PC. Brave had the “Verified” badge.

However, on the new install, there is no option to “Verify Wallet”, and no “Verified” badge.


Is this working as intended? Or should I be seeing “Verified”?

Version 1.5.122 Chromium: 80.0.3987.162 (Official Build) (64-bit)

Same on Beta build:
Version 1.7.83 Chromium: 80.0.3987.162 (Official Build) beta (64-bit)

Seems like you downloading the Japanese version of Brave. See that it’s said “BAT Points (BAP)” instead of “BAT”.

Did you using VPN when download it from

I would suggest you to redownload Brave. But maybe @mattches @asad @steeven have a better suggestion.

Thanks for the response.

I’m living in Japan so that may be why I ended up with the Japanese version. And I was wondering why it changed to BAP all of a sudden!


As per your suggestion, I’ve just tried uninstalling, and using a VPN to download from US and again from Australia, but still same result.

Any other suggestions much appreciated.

Found a way to get it done:

  1. Close Brave.
  2. Open Preferences file inside %AppData%\Local\BraveSoftware\Brave-Browser\User Data\Default
  3. Find the countryid_at_install key.
  4. Change it to another ID. For me, I changed to my original home, Australia (16725).
  5. Launch Brave and check.


Strange that Japan is the only country that triggers the onlyAnonWallet flag:

Any reason for this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.