Brave does not pick up policies on guest mode and new profile creation

Description of the issue:
Even after setting the 2 policies BrowserAddPersonEnabled and BrowserGuestModeEnabled to false (shown and confirmed in brave://policy), I can still open a new guest window and create new profiles.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Download the Brave policies at https://github.com/Prowler2/Brave-Browser-GPO-Policy
  2. Set each of these to false/Disabled.
  3. Go further and change the registry in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\BraveSoftware\Brave
  4. Restart Brave

Actual Result (gifs and screenshots are welcome!):
image
image

Expected result:
These 2 should be disabled.

Reproduces how often:
It’s always been so.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10
Version 1.16.68

Additional Information:
Just so you know, in order to block the settings page in the company, blocking the URL brave://settings in gpedit does not work. I had to use chrome://settings instead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.