Brave Crashes While Selecting or Dragging Page Element on Fedora KDE

Uploaded crash report ID: 08481000-505c-df0b-0000-000000000000
Uploaded crash report ID: 4bb50f00-505c-df0b-0000-000000000000
Uploaded crash report ID: cd960c00-505c-df0b-0000-000000000000

Description of the issue: While selecting or sometimes dragging a selectable page element (text, a link, or an image, for instance), Brave will occasionally crash without warning and will not respond until it is force closed. Restarting it allows one to click the button to restore their session as normal after a crash.

It’s getting so much frustrating to use brave.

2 Likes

Exactly same issue, it is occuring after latest update.
so annoying :frowning:

1 Like

Sometimes it will crash but sometimes it will keep running but reject all mouse inputs.

1 Like

Yes that happens most of the time, only thing you can do is scroll the webpage and nothing else.

Happening on Arch too. I find I can trigger this easily by selecting some text, then try to move it. The cursor change to a little hand and the only thing brave will repond is scrolling. You can quit by clicking the window’s close icon and using enter to confirm the dialog (clicking does not work…). This started with the 1.65.x series (and maybe eariler in the late 1.64.x series). I am using kde and wayland using Arch’s stable repos, fully up to date.

1 Like

looking into this. It looks like chromium bug:
https://issues.chromium.org/issues/336449364
which is caused by a kde (or qt) bug:
https://bugs.kde.org/show_bug.cgi?id=482142
in any case, the chromium devs agree it should not stop responding to mouse clicks and have produced a test fix:
https://chromium.googlesource.com/chromium/src/+/876fbd5552c8fb9d4889ba0371e4d7e3bfa9af84^!/
but have not merged it yet. It would be VERY nice to see this in brave asap.
TIA

3 Likes

Any update on when the devs are going to merge the fix?

Why is no dev addressing this issue, even with a version change the issue still persists. It’s a lot of pain to switch browsers, so if any dev is seeing this post please inform the concerned team.

I tried to crash brave flatpak by draging-droping web elements, but it’s not crashing. Can you guys verify the same at your end? If it’s so it’ll be better to switch to flatpak edition. @edtoml @LeHoax @tr1ten

Hi, I think another workaround is going to brave://flags/ and changing “PreferredOzone platform” to “X11”.

Using the flatpak version has the same effect because it uses xwayland instead of native wayland. The issue with wayland + Kwin probably will be fixed in KDE-Plasma version 6.0.5

1 Like

It IS still happening here. Kde plasma 6, try selecting text on any page and dragging. Have to restart brave many times every day.

Edit: Issue got fixed after plasma 6.0.5 update.

Tried it,changed “PreferredOzone platform” to “X11” it didn’t worked for me.
But when I changed it to default, which treats it as X11, then it stopped crashing.
Thanks though for telling me this work around, I checked the flatpak version it is also set to the default option, i guess that’s why it’s not crashing.