Brave crashes when search bar is clicked

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:

How can this issue be reproduced?

  1. Open brave. Search for anything using search bar. Click any search result link. Return to search results and click onto search bar again. Brave will crash.

Expected result:
Brave should allow a new search query to be entered.

Brave Version( check About Brave):
1.46.154

Mobile Device details
Kyocera Duraforce pro 2. Also Samsung A7 lite tablet.

Additional Information:
Issue happens with any search engine. I have cleared app data and cache, also reinstalled. Will not let me upload screen recording as a new user.

2 Likes

Hello @121wfo

Thanks for bringing this to our attention and I’m sorry to hear you are going through this. Can you please go to brave://crashes and

  • if you have automatic crash reporting is enabled (Settings --> brave shields and privacy --> Automatically send diagnostic reports), please respond back here with the crash report ID
  • If Automatically send diagnostic reports is not enabled, ensure you click Send on these crash reports listed on the page, then reply here with the crash report ID.

Regards!

Alice,
The crash id is 590b0900-d60f-7509-0000-000000000000

I sent all of them from yesterday. All have the same crash id.

Thank you for responding. Let me know how I can assist further!

Alice,
Correction. They id’s are not all the same. But I’m guessing you don’t need them all. Let me know if you do.

Thank you!

Hi again! @121wfo

Thanks for the information and for now I don’t need them all, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, I will get back to you as soon as possible.

Regards!

Hey Alice,

I am facing the same problem and it’s been going on for more than a month. I tried to figure out the problem on my own and here is what I found:

It crashes only with search engine “Duckduckgo” and “Bing”. I opened the browser and searched for something on the address bar. I clicked on one website and then returned back to the search results. I clicked on the search bar(not on the brave search bar/address but the website search bar). And it crashed every time. I did the same thing with other search engine and it works fine. I hope this will help.

Brave Version: 1.47.175

Mobile Device Details: Realme (RMX2040)

Hopefully this will get fixed soon. Thanks!

1 Like

Gig/Alice,
For me it happens with any search engine. Though the frequency of the crashes does seem to vary with them. Google will crash every single time. As well as DDG.

Hi @121wfo , unfortunately the crash stack is inside Android OS autofill service. Could you please tell more about the problem?

  1. Do you have any Autofill service selected in Settings?
  2. In your steps, do you use an URL bar of a browser to make a search or an actual search field on a webpage?

Serg,
1: The only autofill service I enable is Bitwarden.

2: I use the url bar on the Brave homepage for an initial search. Once the search results appear in a search engine, I click on any result. If I then navigate back to the search results page of the search engine, click on the search bar of the search engine itself, Brave will crash.

Thanks @121wfo , I’m going to check with Bitwarden.

Anytime. Let me know if I can help in any way.

No luck on my side with Bitwarden. Are you able to try on Chrome? I’m just trying to understand did we inherit it from upstream or not.

Just tried with Chrome. I can confirm the same behavior. Also tried Firefox, just to throw in a non Chromium browser. It did not do it there.

thanks @121wfo , I will check more of what we can do here or will try to dig upstream issues as most likely they are aware of the problem and working on the solution.

Thanks @Serg. I’m just hitting the home button after every search for now. A little annoying, but really no extra steps.

Turn off AutoFill services, i had the same problem when i had Bitwarden Auto fill enabled. turning it off did it for me.

@Ivar I will try this. That’s kind of a serious downer though.