Brave Crashes Using Private TOR tab after pressing the Enter key


#1

Description

When attempting to use a “New Private Tab with Tor”, the tab opens fine, I type something (anything) in the search bar, e.g. google.com then I press the “Enter” key and the browser closes completely. This only happens with a Tor tab.

Steps to Reproduce

1.Start Brave
2.Open Tor private tab
3.enter anything in address bar and press enter

Actual result:

Brave closes.

Expected result:
I would expect the term I enter would be searched on when I press the enter key

Reproduces how often:

100%

Brave Version

about:brave info:

|Brave|0.23.19|
|V8|6.7.288.46|
|rev|178c3fb|
|Muon|7.1.3|
|OS Release|6.1.7601|
|Update Channel|Release|
|OS Architecture|x64|
|OS Platform|Microsoft Windows|
|Node.js|7.9.0|
|Tor|0.3.3.7 (git-035a35178c92da94)|
|Brave Sync|v1.4.2|
|libchromiumcontent|67.0.3396.87|

Reproducible on current live release:

I believe so

Additional Information


#2

Hey @brianwraith,
Thanks for reaching out to us with this issue - also excellent report! :slight_smile:

While I dig into this issue, you said that after opening a tor private tab and pressing enter in the URL bar to go to a specified address, the browser crashes. Does the browser crash if you use a tor tab without pressing enter? To test:

  • Open Brave
  • Open tor private tab
  • Type an easy to enter URL somewhere other than the URL bar (for example, open notepad and type www.reddit.com)
  • Cut the URL you typed, right click the URL bar in Brave, select “paste and go”
    Does the browser still close?

Thanks!
Brave Team


#3

Hello @Mattches, following your instructions the browser did not close. I then tried typing in the URL field and pressing enter and it remained stable, opened up an additional TOR tab, typed, pressed enter and still stable.

Closed Brave, opened it again, opened a Tor tab, typed google.com in the URL field, pressed enter and it closed again. I restarted it again, tor tab then typed nsa.gov and it remained open and resolved the address.

I am not typing out every attempt but it seems that it closes most often when typing google in the url field and pressing enter. Other sites seem to resolve.


#4

After looking around it does seem like we have a very similar issue logged already:https://github.com/brave/browser-laptop/issues/12975

While we are working on this, if you can produce verifiable steps to reproduce it would certainly help us track the error down. You can look here for more information on “steps to reproduce (STR)” and how to report a bug. Feel free to copy and paste the template to make filling it out easier and reply here :slight_smile:


#5

The problem you cited doesn’t seem to resemble the problem I am experiencing.

I already used the template in my initial report. I will simply give you the steps again:

  1. Windows 7 professional
  2. Open Brave
  3. Open new private tab with Tor
  4. type “google” in the URL field of the Tor tab.
  5. press enter
  6. Brave closes instantly.

#6

Thanks for the steps, we appreciate that :slight_smile:

We can’t seem to reproduce the bug on our end. We would like to try and get a bit more information surrounding the issue, but in order to do so, we’ll need you to download a git for windows and launch Brave from the terminal and observe the error log (in terminal) when Brave crashes. If you know how to do this already, reply with the error log. If not, don’t worry, its not too complicated. Do the following:

  • Go to https://gitforwindows.org/ and download Git for Windows
  • Install it with default settings - no need to change anything
  • Once downloaded, type “Git Bash” (no quotes) into your windows search bar
  • When the terminal shows up, navigate to the directory in which Brave is stored (if you don’t know how to do this in the terminal, you can find where it is using windows normally and when you get there, right click and copy the path, go back to git, type cd, then right click and paste the path, then hit enter).
    Once there, type start Brave.exe (or whatever you may have named it), then produce the error again. Let us know what is displayed in the terminal and if you need help at any point please don’t hesitate to let us know :slight_smile:

#7

Adding in my two cents, mine only crashes when I try to access blocked sites via my employer’s network. So I can load normal pages but pages which my company has flagged will cause Brave to crash. Did this for testing purposes. My company is using Cisco ScanSafe btw.


#8

Mac, “tor” crashes immediately after Brave start and each time I attempt to open Tor Tab.

Report

Process: tor [54691]
Path: /Applications/Brave.app/Contents/Resources/extensions/bin/tor
Identifier: tor
Version: 0
Code Type: X86-64 (Native)
Parent Process: Brave Helper [54322]
Responsible: Brave [54315]
User ID: 501

Date/Time: 2018-06-29 14:32:59.516 +0300
OS Version: Mac OS X 10.11.6 (15G21013)
Report Version: 11
Anonymous UUID: —

Sleep/Wake UUID: —

Time Awake Since Boot: 880000 seconds
Time Since Wake: 34000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Dyld Error Message:
Symbol not found: _getentropy
Referenced from: /Applications/Brave.app/Contents/Resources/extensions/bin/tor (which was built for Mac OS X 10.13)
Expected in: /usr/lib/libSystem.B.dylib

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 dyld 0x00007fff623ad075 dyld_fatal_error + 1
1 dyld 0x00007fff623b0094 dyld::fastBindLazySymbol(ImageLoader**, unsigned long) + 139
2 libdyld.dylib 0x00007fff96723262 dyld_stub_binder + 282
3 ??? 0x0000000108eb30b0 0 + 4444598448
4 tor 0x0000000108c52c05 crypto_seed_rng + 85
5 tor 0x0000000108c52af2 crypto_early_init + 226
6 tor 0x0000000108bb84d5 tor_init + 149
7 tor 0x0000000108bb90b8 tor_run_main + 104
8 tor 0x0000000108c2b586 tor_main + 70
9 tor 0x0000000108af2e1b main + 27
10 libdyld.dylib 0x00007fff967255ad start + 1

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x00007fff623e6290 rbx: 0x00007fad01c0b970 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x00007fff623e6400 rsi: 0x0000000000000000 rbp: 0x00007fff5710d110 rsp: 0x00007fff5710d0f8
r8: 0x00007fff623cf04c r9: 0x00000000fffff800 r10: 0x00007fff5710cee5 r11: 0x00007fff623e6400
r12: 0x00007fff5710d610 r13: 0x00007fff5710d610 r14: 0x00007fff623e6400 r15: 0x0000000000000020
rip: 0x00007fff623ad075 rfl: 0x0000000000000246 cr2: 0x0000000109048335

Logical CPU: 2
Error Code: 0x00000000
Trap Number: 3

Binary Images:
0x108af2000 - 0x108eb21e3 +tor (0) <251521AD-DE17-32C8-ADAF-EFC9D3ADED42> /Applications/Brave.app/Contents/Resources/extensions/bin/tor
0x109027000 - 0x109027ff7 liblaunch.dylib (765.70.1) <96D7C3EE-82E2-39AB-870F-B317A030E86D> /usr/lib/system/liblaunch.dylib
0x10902f000 - 0x109032fff libsystem_sandbox.dylib (460.60.4) <71D697CA-7339-37C7-8DAF-3BAA1D57B56A> /usr/lib/system/libsystem_sandbox.dylib
0x109040000 - 0x109069ff7 libxpc.dylib (765.70.1) <4FB1311F-4032-3F56-BF0B-CFF45D78FB01> /usr/lib/system/libxpc.dylib
0x7fff623ac000 - 0x7fff623e3a47 dyld (360.22) <6B9CD3BA-2D60-3629-A0CB-AB810F55E8DD> /usr/lib/dyld
0x7fff8610c000 - 0x7fff8610dffb libremovefile.dylib (41) <552EF39E-14D7-363E-9059-4565AC2F894E> /usr/lib/system/libremovefile.dylib
0x7fff87f53000 - 0x7fff87fe0fef libsystem_c.dylib (1082.60.1) <0F0C7ED5-3902-3427-9C1D-E2F130B528C5> /usr/lib/system/libsystem_c.dylib
0x7fff88aac000 - 0x7fff88ab4ffb libsystem_dnssd.dylib (625.60.4) <80189998-32B0-316C-B5C5-53857486713D> /usr/lib/system/libsystem_dnssd.dylib
0x7fff89803000 - 0x7fff89808ff3 libunwind.dylib (35.3) /usr/lib/system/libunwind.dylib
0x7fff8b52b000 - 0x7fff8b533fff libsystem_networkextension.dylib (385.40.36) <66095DC7-6539-38F2-95EE-458F15F6D014> /usr/lib/system/libsystem_networkextension.dylib
0x7fff8bb22000 - 0x7fff8bb51fc3 libsystem_m.dylib (3105) <8A645D53-92DD-3C2E-8AFA-F28BC63E3657> /usr/lib/system/libsystem_m.dylib
0x7fff8d2cc000 - 0x7fff8d343feb libcorecrypto.dylib (335.50.1) /usr/lib/system/libcorecrypto.dylib
0x7fff8d41b000 - 0x7fff8d445ff7 libc++abi.dylib (307.4) /usr/lib/libc++abi.dylib
0x7fff8d8cd000 - 0x7fff8d8cffff libsystem_coreservices.dylib (19.2) <1B3F5AFC-FFCD-3ECB-8B9A-5538366FB20D> /usr/lib/system/libsystem_coreservices.dylib
0x7fff8dd7a000 - 0x7fff8dd81ff7 libcompiler_rt.dylib (62) /usr/lib/system/libcompiler_rt.dylib
0x7fff8ef93000 - 0x7fff8efa4ff7 libz.1.dylib (61.20.1) /usr/lib/libz.1.dylib
0x7fff90aa8000 - 0x7fff90b0eff7 libsystem_network.dylib (583.50.1) /usr/lib/system/libsystem_network.dylib
0x7fff919a8000 - 0x7fff919adff7 libmacho.dylib (875.1) <318264FA-58F1-39D8-8285-1F6254EE410E> /usr/lib/system/libmacho.dylib
0x7fff923bd000 - 0x7fff923befff libsystem_blocks.dylib (65) <1244D9D5-F6AA-35BB-B307-86851C24B8E5> /usr/lib/system/libsystem_blocks.dylib
0x7fff92d05000 - 0x7fff93067f3f libobjc.A.dylib (680) <7489D2D6-1EFD-3414-B18D-2AECCCC90286> /usr/lib/libobjc.A.dylib
0x7fff93108000 - 0x7fff93108ff7 libkeymgr.dylib (28) <8371CE54-5FDD-3CE9-B3DF-E98C761B6FE0> /usr/lib/system/libkeymgr.dylib
0x7fff93efc000 - 0x7fff93f0dff7 libsystem_trace.dylib (201.10.3) <4D757E1E-B823-3D29-9189-82B261FF2225> /usr/lib/system/libsystem_trace.dylib
0x7fff93ffe000 - 0x7fff93ffeff7 libunc.dylib (29) /usr/lib/system/libunc.dylib
0x7fff94cce000 - 0x7fff94ce5ff7 libsystem_asl.dylib (323.50.1) <41F8E11F-1BD0-3F1D-BA3A-AA1577ED98A9> /usr/lib/system/libsystem_asl.dylib
0x7fff94e68000 - 0x7fff94e6aff7 libsystem_configuration.dylib (802.40.13) /usr/lib/system/libsystem_configuration.dylib
0x7fff95273000 - 0x7fff95274fff libDiagnosticMessagesClient.dylib (100) <4243B6B4-21E9-355B-9C5A-95A216233B96> /usr/lib/libDiagnosticMessagesClient.dylib
0x7fff95758000 - 0x7fff95760fef libsystem_platform.dylib (74.40.2) <29A905EF-6777-3C33-82B0-6C3A88C4BA15> /usr/lib/system/libsystem_platform.dylib
0x7fff9590a000 - 0x7fff95912fff libcopyfile.dylib (127) /usr/lib/system/libcopyfile.dylib
0x7fff95913000 - 0x7fff95959ff7 libauto.dylib (186) <999E610F-41FC-32A3-ADCA-5EC049B65DFB> /usr/lib/libauto.dylib
0x7fff96722000 - 0x7fff96725ffb libdyld.dylib (360.22) /usr/lib/system/libdyld.dylib
0x7fff979f2000 - 0x7fff97a10ff7 libsystem_kernel.dylib (3248.73.10) <6EB191A4-3A40-3835-BDC6-73448AC2832B> /usr/lib/system/libsystem_kernel.dylib
0x7fff984a1000 - 0x7fff984a3ff7 libquarantine.dylib (80) <5B351BEC-27CC-3935-82F3-A065CC764255> /usr/lib/system/libquarantine.dylib
0x7fff99140000 - 0x7fff99149ff7 libsystem_pthread.dylib (138.10.4) <62FC23B9-1DEE-3918-A30D-A58EC95A0720> /usr/lib/system/libsystem_pthread.dylib
0x7fff991c3000 - 0x7fff991c4ffb libSystem.B.dylib (1226.10.1) /usr/lib/libSystem.B.dylib
0x7fff991c5000 - 0x7fff991ceff3 libsystem_notify.dylib (150.40.1) /usr/lib/system/libsystem_notify.dylib
0x7fff9990e000 - 0x7fff99912fff libcache.dylib (75) <9548AAE9-2AB7-3525-9ECE-A2A7C4688447> /usr/lib/system/libcache.dylib
0x7fff9a00a000 - 0x7fff9a026ff7 libsystem_malloc.dylib (67.40.1) <5748E8B2-F81C-34C6-8B13-456213127678> /usr/lib/system/libsystem_malloc.dylib
0x7fff9aae1000 - 0x7fff9aae2fff libsystem_secinit.dylib (20) <32B1A8C6-DC84-3F4F-B8CE-9A52B47C3E6B> /usr/lib/system/libsystem_secinit.dylib
0x7fff9b4f1000 - 0x7fff9b4fcff7 libcommonCrypto.dylib (60075.50.1) /usr/lib/system/libcommonCrypto.dylib
0x7fff9be33000 - 0x7fff9be86ff7 libc++.1.dylib (120.1) <8FC3D139-8055-3498-9AC5-6467CB7F4D14> /usr/lib/libc++.1.dylib
0x7fff9beaa000 - 0x7fff9bed3fff libsystem_info.dylib (477.50.4) /usr/lib/system/libsystem_info.dylib
0x7fff9befa000 - 0x7fff9bf27fff libdispatch.dylib (501.40.12) /usr/lib/system/libdispatch.dylib
0x7fff9c5d5000 - 0x7fff9c5ecff7 libsystem_coretls.dylib (83.40.5) /usr/lib/system/libsystem_coretls.dylib

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 36620582
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=104.0M resident=0K(0%) swapped_out_or_unallocated=104.0M(100%)
Writable regions: Total=46.4M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=46.4M(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Activity Tracing 2048K 2
Kernel Alloc Once 4K 2
MALLOC 36.2M 8
MALLOC guard page 16K 4
STACK GUARD 56.0M 2
Stack 8192K 3
VM_ALLOCATE 4K 2
__DATA 1720K 44
__LINKEDIT 92.7M 7
__TEXT 11.3M 44
shared memory 8K 3
=========== ======= =======
TOTAL 207.9M 110

Model: MacBookAir6,1, BootROM MBA61.0107.B00, 2 processors, Intel Core i5, 1,4 GHz, 4 GB, SMC 2.12f143
Graphics: Intel HD Graphics 5000, Intel HD Graphics 5000, Built-In
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1600 MHz, 0x80AD, 0x483943434E4E4E384A544D4C41522D4E544D
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1600 MHz, 0x80AD, 0x483943434E4E4E384A544D4C41522D4E544D
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x117), Broadcom BCM43xx 1.0 (7.21.95.178.1a2)
Bluetooth: Version 4.4.6f3, 3 services, 19 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD TS0128F, 121,33 GB
USB Device: USB 3.0 Bus
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Air, Apple Inc., 23.6


#9

@s-kot It sounds like if it’s just the tor process that crashes, and not the whole Brave browser, then your issue is more likely to be: https://github.com/brave/tor_build_scripts/issues/18 The other issues look more like https://github.com/brave/browser-laptop/issues/12975 as noted, which may need more feedback to investigate and debug.


#10

Oh, it’s already there :slight_smile:
I just found a 100% reliable method to crash Brave, OS is Windows-7, Brave version according to about Brave:

Brave: 0.23.31
V8: 6.7.288.46
rev: 3148acef36dba0fce89108638bb27927c4937f90
Muon: 7.1.5
OS Release: 6.1.7600
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 67.0.3396.103

How to crash Brave every time:

Nothing is blocked here, but I get “This site cannot be loaded due to a certificate error: https://www.wikipedia.com/” if I type it into a new tab created with Ctrl-T.

Hope this helps :slight_smile: I have to send this off before I try opening https://www.wikipedia.com in a private tab with Tor without going to the torproject page first, because I already know that this post will be gone after a restart, guess why I know this :stuck_out_tongue: In addition, Brave has (so far) never crashed whatever I did in a normal new tab but I had a few unreproducible crashes with private tabs with Tor. Alas, this is the first time I can provide a recipe to crash it 100% reliable every time. Not sure whether the other tabs are involved or not.

Edit: Now it can’t connect to the Tor network anymore and the task manager shows clearly more Brave-processes than there should be. Time to go for some killing…

Edit 2: All these processes vanished when I closed Brave. It starts 11 processes with 1 window that contains 5 tabs :astonished: OK, next try…

Edit 3: It still doesn’t connect to the Tor network. So no more testing for today.

Edit 4, nearly a day later: Still doesn’t connect to the Tor network. I give up on Tor.


#11

Hmmm… Can’t say that version 0.23.39 is a big improvement in respect to crashes involving private tabs with Tor.

  • “Copy Link Address” from “www.torproject.org
  • Open a new private Tab with Tor
  • Insert the copied link into the address field of this tab
  • Hit the Return-key – Brave vanishes immediately.

My OS is still Windows-7. Brave full version:
Brave: 0.23.39
V8: 6.7.288.46
rev: a38be75ccb0f699f507b66c4d44b3b21d1677e25
Muon: 7.1.6
OS Release: 6.1.7600
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 67.0.3396.103

Edit: Additional hint: Brave is installed in C:\Users\ (username) \AppData\Local\brave\ - not system-wide! Sorry for not mentioning this earlier.

With version 0.23.31 it crashed the first time of inserting a copied URL, then no more and some manual typing was required to crash it.
With version 0.23.39 it crashed 3 times in a row following my recipe (above in this post), then it doesn’t connect to the Tor network anymore.


#12

Thank you for your input.

I was able to reproduce the issue on Windows 7 machine. We will work hard to solve this issue.

You can track the progress here:


Browser Crash when using Private Tabs with Tor
Browser Crash when using Private Tabs with Tor
#13

Edit: Oops, spoke too soon, Version 0.23.73 still crashes when first going to some website within a private tab with Tor (e.g. following the “learn more” link) and then replacing that URL with “https://google.com” and hitting return.


#14

Same problem here, latest Brave as of a few days ago when I updated. Win7.

Start Brave, all is fine. Open a Tor tab, type something into URL bar, hit Enter key then Brave closes. Now comes the informative part: After a few times of doing that, then Brave on the TAB tab worked fine.

Today’s experience: same as previously, Brave closes twice after hitting Enter. But now I get stuck in the “Unable to connect…” dialogue. Clicking to try again does nothing. Clicking to leave TOR at least lets me use the browser again. But I get stuck in “Unable to connect…” endlessly now.

So it’s intermittent for me. No VPN in use.


#15

I recently experienced this as well. The irony is that I have managed to use private tabs with tor to go to specific website, but maybe it’s because I was trying to use it to search that made the browser crash bug happen.