Brave cannot load Walmart.com even in Private Window

Brave cannot load Walmart.com even in Private Window.
Please fix this bug.
Thank you!

v1.40.113 Brave is up to date

Version 1.40.113 Chromium: 103.0.5060.114 (Official Build) (x86_64)

Hi @johnnybegoode
to be honest i think this is not a bug in brave.
Maybe something with your internet connection.

I can open that site without any problems.

greetings

I also just checked that site and it loaded without any issues.

My ethernet speed is 500/500.
I have cleared all browsing data too.
The site runs perfectly using Safari.

Is there anything else I could do?

Do a favor and Create a new profile as a test. If you don’t know how to do this, click the “hamburger menu” (top right menu, three lines) and choose it as an option. This isn’t erasing anything and is just tempoary to see if things will work. Within your new profile, check if the issue persists.

Btw, side note, Brave just rolled another update since. Current is Version 1.41.96
. I doubt that will change anything, but figured I’d point it out.

Other troubleshooting steps:

  1. Change setting for Enable Hardware Acceleration under brave://settings/system and see if it fixes anything.

  2. I see you cleared browsing data, but you didn’t say cookies and site data. Not sure if different word or you didn’t do. Go to brave://settings/content/all and search for Walmart. Then select Clear Data. It will clear everything from Walmart’s site, which will log you out and make you log in again. It will also clear anything if you had something in your cart. But that’s all. See if that resolves.

Thank you all. Problem solved.
I just clicked wait a few times and after that things run smoothly again.

1 Like

@johnnybegoode

If your connection with ‘walmart.com’ becomes a struggle . . .

Recommended GLOBAL SHIELDS settings:

In a Brave Browser - New Window, go to: brave://settings/shields

  • Enable: Show the number of blocked items on the Shields icon

If ‘Default view’ option is available, select: Advanced view

  • Disable: Auto-redirect AMP pages (AMP - Google’s Accelerated Mobile Page)
  • (Alternate setting for older Brave Browser versions, try: Disable Enable De-AMP at brave://flags)
  • Enable: Prevent sites from fingerprinting me based on my language preferences
  • Trackers & ads blocking: Agressive
  • Enable: Upgrade connections to HTTPS
  • Enable: Block scripts
  • Block fingerprinting (aka Fingerprinting blocking): Strict, may break sites
  • Block cookies (aka Cookie blocking): Only cross-site

Recommended in order to reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

In a Brave Browser - New Window, go to: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows

In a Brave Browser - New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter [*.]walmart.com:443 as the site . . . but Do Not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for:

  • https://csp.walmart.com:443
  • https://www.walmart.com:443

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.]walmart.com:443 as the site . . . but Do Not Enable

  • Current Private session only

Click the Add button

Repeat those steps for:

  • [*.]wal.co:443
  • [*.]walmart.com:443
  • [*.]walmartimages.com:443
  • https://www.google.com:443

I do not have the “Current Private session only” option.

@johnnybegoode

Have you updated to Brave Browser (for desktops) v1.41.96?

Brave is up to date


Version 1.41.96 Chromium: 103.0.5060.114 (Official Build) (x86_64)

Can you test with shields up? @johnnybegoode Going by the screenshot, not sure why it was disabled

Thanks, everybody!

Actually, everything seems to be working fine now.
I reverse these following because many sites do not work well with them.

I used standard for these:

  • Block fingerprinting (aka Fingerprinting blocking): Strict, may break sites
  • Trackers & ads blocking: Agressive