redirects to account sign-in screen (Brave Linux and Mac, Not FF or Safari)

Anyone else? Or any advice (besides don’t shop there…)

Started a couple of days ago. Private or not. Shields up or not. Brave is always latest offered update for the OS being run.

Goto, wait or enter a search term, window redirects to walmart’s log-in screen. So can’t peruse the website.
Reproduced in Brave Linux 1.56.20 (Mint 20.3 on older PC), and Mac (Catalina in a VM, current Brave 1.56.20), and last compatible Brave in El Capitan 1.41.100, on iMac 2013ish)
OK in FireFox and Safari.
Don’t have Chrome installed anywhere to test.

Just tried it. No problems logging in with shields completely up.
That is on a PC with Win 10.

More details about your set up?

Thanks for checking your Win 10. (Don’t have a Windows setup here to test.)

Sorry wasn’t clear. Logging in to walmart is not the problem.
The problem experienced is a forced redirect to
IOTW, cannot browse the website unless you log-in at that point.

Only experiencing this with Brave.
A new Brave install in a new Catalina VM still redirected.
An install of the latest Chrome, however, was fine when tried in the same Catalina VM, where Brave redirects to login in a few seconds.

More details about your set up?
On Mac Hardware: El Capitan, Virtual Machine running Mac Catalina, VM running Linux Mint 20.3.
On PC hardware: Linux Mint 20.3.

I experienced what @re9321 reports too (a request for email or that I sign in), starting about a week ago.

I have no recollection why (this would date back A Long Time), but my default Shields setting for Walmart was 'Shields Down'. Toggling Shields to 'UP' when this first occurred mostly resolved the issue. “Mostly”: I have access to the site, but the site search bar no longer attempts to auto-complete my entries - no big deal. It didn’t occur to me to report this because I have extensions installed (NoScript, uBlock Origin) that I thought might be confusing the issue. As I write this, the Walmart site appears to be functioning adequately for me using Brave with Shields UP. I didn’t try the website with the other browsers I have installed.

Suggestion (echoing what @Meeker-Morgan mentioned in passing): check the status of Brave Shields. If not UP, toggle Brave Shields to UP.

Debian GNU/Linux 11 bullseye (x86-64)
Brave 1.56.20

Checked browsing while logged off.
No problems.

I am having the same problem from last few days. Walmart redirects to login page. Tried after clearing cookies, cache, different internet connection, but nothing has changed. It works with other browser (firefox).

Really need a solution…

I am on win10 and this is happening with me also. For me, it started a couple of days ago.

Me either. I thought it was a “new thing” that Walmart was implementing. lol Didn’t make sense to me because could really alienate new customers… guess it isn’t a Walmart thing after all. :wink:

Brave Version & OS:
Brave 1.56.20 Chromium: 115.0.5790.171 (Official Build) (64-bit)
OS Windows 10 Version 22H2 (Build 19045.3208)

Following up on this: I don’t visit the Walmart site frequently - maybe once per month - hence, didn’t pay close attention to the site’s new behavior - “new” as of approximately end-of-July.

I did visit the Walmart site today using Firefox (102.10.0esr).

Specific to this complaint - a request to sign in or for an email address - that request doesn’t appear when I visit the site using Firefox. Beyond that, using Firefox, the Walmart site is fully functional. I can search for products and the various drop-down menus function as expected.

Visiting the Walmart site using Brave-with-Shields UP: no request for an email address or that I sign in; the site’s search bar is somewhat functional; all the drop-down menus are disabled. With a URL for a specific product, I can visit that page, but again, none of the drop-down menus function.

I’ve not installed Chrome in my Linux instance / don’t see the need to, and this experience doesn’t change that.

Which is to say: for me, so long as this behavior continues, I’ll not use Brave to visit the Walmart site. Firefox works fine. I use a 3rd party password manager. This yet again emphasizes why using a 3rd party password manager is IMHO a Good Idea. I can sign into the Walmart site - if I choose to - while using any browser.

No complaint - certainly no hissy-fit - this is merely a report of how Brave behaves visiting a specific website. Walmart is not an obscure rarely-visited merchant. If this experience expands beyond Walmart’s site - and if Firefox’s functionality continues unimpaired - I’ll use Brave less and Firefox more. I do have both browsers installed / open at the same time / and I use the browsers for different purposes. This experience merely weighs the frequency with which I use each browser away from Brave and toward Firefox.

Same problem here on Win 10 and Android browsers. Started about a week ago. Annoying as hell

Hi Emi. :slight_smile: Thanks for the information. Appreciate your effort to find a workaround!

Entering your script in custom filters does stop the sign-in screen popping up, but some of the sub-menus are still not working, like departments and services. Also, some of the normal merchandise displays are grayed out. The merchandise that does display, the links work but again, some of the links that should be working are not.


Tagging @Mattches

Additional info:

  1. I do not use extentions.
  2. Problem occurs in new profile.
  3. Problem occurs in Beta 1.57.35
  4. The login screen does not occur in Nightly 1.58.72 but the broken links’ problems are.
  5. No errors displayed in devtools for any version.

Nightly is currently updating. Will let you guys know if anything changes.


  1. Nightly 1.58.77 - Some menu links and merchandise display still broken.
  2. Beta 1.57.35 - I said no errors in devtools, but Beta does have errors. Snip below. No errors displayed in Stable version or Nightly.


@Chocoholic @anon57438784 Thanks for the suggestions and the updates.

For the rest of us mere mortals, it appears using a-browser-other-than-Brave (and a non-browser-specific extension-based password manager) is a near-term workaround.

@emi Sorry for delay. Just popped in for a minute and just saw your post.

New script didn’t work. Same problems exist with links and display. Just tried it in Release 1.56.20 and not Beta and NIghtly.

I’m a mere mortal too! lol Emi is the one who understands this stuff. :stuck_out_tongue:

Popping out again. I’ll check back tomorrow for any new messages. Wondering if an issue report needs to be opened at GitHub… I looked but couldn’t find anything that may be related. Hopefully @mattches will pop in and provide additional info on this issue.

Thanks again Emi! :slight_smile: Take care all. :slight_smile:

@Emi Seems to be working fine now. Tried with and without your script and the site is working. If anything changes, I will post an update.

My Resource file was updated to 1.0.54.


Did you create an issue report? Can you provide a link? I still can’t find an issue report about this! Even looked in adblock related repositories and nothing.

@redbike9 Is is functioning properly for you now?

Thanks again Emi and take care all. :slight_smile:

I found where you posted the link in another topic (Brave Blocker YouTube stop working). Pasted link below for reference.

And it is awesome that Brave dev is asking you to be more involved. High praise indeed. Good job. :slight_smile:

Simple answer: no.

Details: I have Brave installed on both a desktop and a laptop. I’m not going to follow @anon57438784’s suggestion on multiple installations. My access to the Walmart site is unimpaired using Firefox, so that’s the browser I’ll use until Brave resolves this issue.

Brave’s release schedule shows v1.57.x should be released August 15, 2023. Perhaps this issue will be resolved in that release.

edited to add: For me, this is a very minor inconvenience. I’d guess I visited the Walmart site more frequently in the past week to check out this issue than I’d visited the site in the previous year. (And continuing to regularly visit the Walmart site is a very low priority on my to-do list.) More broadly, I’ll look to see if other merchants whose sites I visit adopt Walmart’s behavior. One benefit of this specific instance: Walmart is big enough so what it does isn’t going to be ignored.

Just noticed on Android yesterday. Still doing it today, fwiw.


Hi there, thank you to the original poster for bringing awareness to this issue as I am having it happen to me as well.

It’s still happening as of 8/12/23. On walmart’s website I get redirected to a log in page. It happens whether shields up or down, after all data cleared/deleted. After brave app reinstall. Running android 13 on mobile and windows 11 on laptop and happens there as well. Happens in duckduckgo app, but not in chrome interestingly. I don’t want to have to go back to Firefox, but I’ll have to, if issue isn’t fixed, to try it there.

I don’t dare tinker with scripts etc. as I’m another mere mortal too. I’m also not as cool because I do use walmart’s website a fair amount for window shopping, price compare etc. I’d really appreciate to see this fixed. I’d be game to notify developers as well, but I’m a newbie here and it looks impossible to find a way to just notify brave directly. Can’t help it, I find that annoying.

I’m keeping an eye on this thread for helpful info. Thank you again everyone.

1 Like

@Sunnybluff Hi :slight_smile:

The fix for this is released. So, because you are still experiencing an issue, please check and confirm the following:

  1. brave://version
    Should show 1.56.20 for Brave. If it doesn’t, please update.

  2. Also, as mentioned by Emi, please check that your Resources Library is updated.

If everything is updated and you are still having an issue, please post your device and OS information. Also, try creating a new profile and see if the issue occurs in a new profile.

Please post an update. :slight_smile:

@fanboynz can you check into this. I just tested and have similar issue. Problem is occurring on both Release and Nightly. I then tested on Chrome and it doesn’t happen there.

As it’s occurring with me, just simply navigating to immediately sends me to the login page. This occurs regardless of whether Shields is on or off. I’ve also tested across profiles but it made no difference.

(I also tried clearing cookies in case it mattered, but no good)

Also seem to be a number of other people complaining in a 2 year old post on Reddit over at Seems to be multiple comments made in the last 6-7 days. At least some reported issue occurring on other browsers, but seems to especially be targeting Brave.

For those of you still experiencing issues, please post your Brave version and the device and OS you are using. This information may help the development team identify the problem.

My testing results below.

  1. Release 1.56.20 - No issues

    Info at brave://version
    Brave 1.56.20 Chromium: 115.0.5790.171 (Official Build) (64-bit)
    Revision cf9067bf10d8f798c24643029af1d24e275646d6-refs/branch-heads/5790@{#1924}
    OS Windows 10 Version 22H2 (Build 19045.3324)
    JavaScript V8

  2. Beta 1.58.83 - Does not redirect to login but cannot use submenus on main page.

    Info at brave://version
    Brave|1.58.83 Chromium: 116.0.5845.62 (Official Build) beta (64-bit)
    Revision 6790b00a844c526d81126dd437569d1b205979ec
    OS Windows 10 Version 22H2 (Build 19045.3324)
    JavaScript V8

  3. Nightly 1.59.9 - Does not redirect to login but coannot use submenus on main page.

    Info at brave://version
    Brave 1.59.9 Chromium: 116.0.5845.82 (Official Build) nightly (64-bit)
    Revision d3618c5c042f6d4a2451a054183b75901ba653cf
    OS Windows 10 Version 22H2 (Build 19045.3324)
    JavaScript V8

1 Like