Webpage only loads in "private" window

Help please!! I am trying to load this webpage (https://staking.singularitynet.io/) in the Brave browser but when I type or paste this link into the address bar it shows correctly but just opens a completely blank page. However, if I open a “private” window and past the link into the address bar this page opens just fine.
I can open the main website where this page is located (https://singularitynet.io/) without any issue. Then under the “Products” dropdown menu I can select the “AGIX Staking” link and the same problem happens the page opens, the address bar shows the correct address but the page is blank.
I have no problem opening this page in a Chrome browser ( which I am trying not to use) THERE IS NO ISSUE! Just with Brave!!
I have spent several hours troubleshooting - clearing cache, deleting bookmarks & browser history, enabling javascript and anything else I have been able to research on the internet. But NOTHING works to fix the issue!

Anyone’s assistance would be appreciated!

My Brave Version is 1.42.88 this is a brand new install of Brave and it is running on Windows 10 64 bit.

Thank you for your time.

Try disabling all the extensions, and then try in normal window mode?

fanboynz THANKS! for your response - I had already tried that and it did not work. However this morning I was able to get the page to load by using a “private” window - still can’t figure out why but seems somehow to be related to cache even though I had deleted everything from cache and history.

@fanboynz Did you happen to test that yourself? I just went to the link they provided, the https://staking.singularitynet.io/ and it was blank page for me as well. Switching to Private made the difference. Disabling extensions did nothing, neither did toggling Shields off/on.

As OP stated, it does open perfectly in Chrome and in Private window, just not in Brave on normal window for some reason.

1 Like

Hey Saoiray, yeah I did test it myself and everything you said is correct - disabling extensions didn’t work - - seems like a bug to me. Funny thing is is you go to https://singularitynet.io site and pull down the “Products” menu you get six choices - all load pages correctly except the “staking” page and the “AI Publisher” page - both just load blank pages EXCEPT in Brave “private” window.

Further testing, I suspect its something to do with referrer’s between pages. Still looking into it


Same problem here,
working fine on Edge not on Brave.
Would be a nice to have.

btw. SNET is an amazing Project!

Hey fanboynz, any further info re this issue? I know you said you were going to do further testing. I still have the same problem and am thinking I’ll just have to throw away Brave since I can’t get it to work and need the access. Have a great day!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

i read this thread today and i know the solution for this

Since its locked, im adding solution here so it helps someone in future who has this same issue

  1. create a new profile on brave and load the problematic website which loads only on private window and not on normal window
  2. click on the lock icon and select cookies

see all cookies list

Now go to


search for all of the sites that you saw in cookies list and delete them there.

After deleting, the issue will still not be fixed but that’s mostly due to you have opened multiple windows like 4 or 5 windows and had the problematic site loaded on them…

Thoroughly inspect all open tabs and close all tabs of the problematic site first…

once every single tab of the problematic tab is closed, the issued will be fixed and site will start to load properly.

i had this issue

and this i how i fixed, simply deleting cookies and cache wont work, you need to close all tabs that you have loaded across different windows first to fix this issue.

This topic was automatically closed after 20 days. New replies are no longer allowed.