Brave browser will not load

I keep getting a message that “Aw, Snap!” “Something went wrong while displaying this webpage.” No matter what I do the browser will not work.

This is my problem – can not access any website with Brave. It worked fine before the 10/24 update to 78.0.70.121

1 Like

This was happening to my users yesterday and again today in Chrome. I believe it has to do with Symantec Endpoint Protection. https://support.symantec.com/us/en/article.tech256047.html
I had to go into the registry, Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies, I added a Google key, and then a Chrome key. In the Chrome key, I created a DWORD called RendererCodeIntegrityEnabled with a value of 0 and this worked.
I am the only one in my office using Brave. I need to know what Keys to add in order to get Brave to work. Hopefully this will point someone in the correct direction.

My computer updated and now NOTHING shows up in Brave. The AwSnap message is on everything. I can’t export bookmarks, nothing! I CANNOT WORK. I HAVE A MEETING AND was printing out some information and everything went to Aw Snap crap. Like I said; I. AM. CRIPPLED. NOW. I cannot do anything at all with Brave other than open and close. Everything attached to brave has crashed with no way of getting my info saved out. No Bookmarks, no history, nothing. Gone. Please help. I am not using anything weird or out of the ordinary. I do not game and do nonsense on the Internet.

Find Brave.exe
Right click on it -> Properties -> Compatibility -> Activate compatibility mode with Windows 8. This is a temporary fix, change it back when an update rolls out.

2 Likes

Thanks Shuka, this worked for me! Much appreciated.

YES! I can use Brave again. Thanks for the tip.

My addons/extensions kept popping up as failed and I went to disable them and the settings page wouldn’t load (Aw Snap Something went wrong).

Thanks @Shuka that helped.

Thank you for answering. I’m using Windows 10. The system says it’s incompatible. I can’t do anything. I have been using Brave just fine for ages! I also saw there was an update at 1:44a.m. and I am positive that is what messed things up. Do you have any other words of advice? Thank you for answering!

Well, I thought I would just go ahead an make it compatible to Windows 8 and there we have it! It’s up and running. Now, to secure my files, etc. Thank you @Shuka! Sincerely appreciative, SWAF

Just saying i have had similar problems. I also have Win 10, and tried right clicking the program (brave install). Troubleshoot compatibility. Nothing I tried worked. Brave went down on Thursday for me, and I haven’t been able to do anything to fix it. At least I can use Chrome, but now I get all those ads!!

hoosiergrandma7: I can temporarily get Brave to come up if I right click the Brave Icon on my desktop, not the taskbar. When the menu pops up, click on Properties, then another window, click the tab Compatibility, then check Windows8, Apply, and ‘OK’, This will work AS LONG AS YOU DON’T CLOSE OUT THE BROWSER. I closed the browser and was back to Aw, Snap! So, I would advise, as soon as you can get up and running, then save your bookmarks.html file to import into Chrome. I hope they get this fixed ASAP. (One more thing: this page in the Chrome browser, which is what I am using right this second, and doesn’t show half the posts in this topic as appears in the Brave browser! Go figure.

1 Like

Thanks for your email. I did try it and it still doesn’t work. I appreciate your help, though.