Brave Browser only shows empty white windows

bug
#1

Don’t see what all the fuss is about with this browser.

Joking, of course. Brave has been getting better and better all along, so I was surprised to see these results yesterday when building out a new Windows 7 machine on an older Core i7 Motherboard with NVidia GeForce GT 1030 GPU. The white windows seem to change color and are sometimes invisible depending on the NVidia driver version I download. I started with the latest NVidia drivers, but they were crashing so I moved back in time about 9 months to get some driver stability. Since the drivers are 500MB download apiece, I was hoping that somebody might be able to comfort me into knowing that this problem is fixable if I just get the right driver version.

Oddly, Brave Browser is the ONLY app that is negatively impacted. And negatively impacted in a MAJOR way, as you can tell from the screen shot :slight_smile:

Brave Browser only shows white windows

Install Windows 7 x64 on an ASRock Z77 Extreme4 Motherboard with an Intel Core i7 3770 (non-k) CPU. Install NVidia Driver version 390.65.

Expect to be able to see contents in a Brave Browser window so I can surf the web.

Reproduces how often:
Always

Brave Version(about:brave):
Can’t see. Latest one offered on 2/13/2019.

Reproducible on current live release (yes/no):
Yes

Additional Information:
None

1 Like
#2

Hi @Whitewashed,
Thanks for reaching out.

We’ve received similar reports from other Win7 users. You may want to try steps mentioned here and see if it can solve your issue. Error on yesterday's update

Thanks
:slightly_smiling_face:

1 Like
closed #3

This topic was automatically closed after 30 days. New replies are no longer allowed.