Brave Browser doesn't know how to connect rewards account to Uphold

Briefly describe your issue:

I have been using Brave Rewards since 2021. I have been receiving regular payouts. First with Gemini, then subsequently with Uphold.

I use Brave Browser on:

  1. iPhone
  2. iPad
  3. Mac Book Pro (M1)
  4. Mac Studio (M1)

I was logged out of both Mac Book and Mac Studio. So I tried logging back in and was successful in connecting my Rewards account the Mac Book. However, on the Mac Studio I am unable to connect. When I login to my Uphold account and hit the green “Authorize” button, I get a popup from Brave Browser which states: “Something went wrong. We weren’t able to complete your request. Please try again, and contact support if the problem persists.”

What Operating System and Brave version are you using (Menu --> About Brave)?

My Operating system and Brave Version on the Mac Studio are:

Mac: Mac OS Sonoma 14.5 (23F79)
Brave: Version 1.66.115 Chromium: 125.0.6422.112 (Official Build) (arm64)

Is your Brave Rewards Profile currently verified? (yes/no)

My Brave Rewards profile is verified

What date did you connect a your Brave Rewards Profile?

On or around 8th January 2021

Have you been able to successfully receive payments in the past?

I have been successful in receiving payments in the past.

Are you using a VPN? (yes/no)

No I am not using a VPN

Are you in a supported region (see here for list of supported regions)?

Yes I am in a supported region.

Does your device pass the SafteyNet check (Android only)?

The SafetyNet check is for Android devices only. My problem exists on an M1 Mac Studio desktop machine.

Have you fully completed Uphold’s CDD requirements?

I have completely completed Uphold’s CDD because I have been receiving payments from Uphold since 8th January 2021.

Some additional points if it helps:

  1. I have deleted all my cookies for Uphold and tried again, however this was not successful.
  2. I have created a new profile and tried again, however this was not successful.

If anyone can give me some tips on how to further troubleshoot this, I would greatly appreciate it. Thank you!

1 Like

2 posts were merged into an existing topic: May 2024 Uphold connection errors (aggregate topic)