Brave browser crashing instantly


Description of the issue:
Every time I attempt to open Brave, a window opens for a split second, then it closes
How can this issue be reproduced?

  1. Open Brave
  2. It Crashes

Expected result:
A window should open

Brave Version( check About Brave):
V1.33.106
Additional Information:

Has anyone found a solution for this? I’m having the same problem vs 1.34.89 Chromium 97.0.4692…71 64bit

Can you both tell me what OS you’re using? We have similar issues open/known right now regarding macOS but not for other OS. Additionally, I see that @Impresar, you’re using v1.33.106 which is outdated – please update to v1.34.80 and check to see if the issue persists.

Note that if the browser doesn’t stay open long enough to initiate an update, you can simply re-download and install the browser from the official website (no need to uninstall your current version – this action will only apply the latest updates to your current installation).

@Weaver I notice that you’re using v1.34.89 – is this a typo and you’re actually on 1.34.80?

Yes, that was a typo. Sorry about that.

Version 1.34.80 Chromium: 97.0.4692.71 (Official Build) (64-bit)
(I copy & pasted this time.)

I’m running Win 10 on both of my machines.

I think I figured out what the problem was with the Android phone. ALL of the sites I
was going to that were crashing the browser stopped when I disabled the brave shields on those sites. So, I reported them as broken sites.

Brave shields doesn’t matter on the Win 10 machines.

@Weaver,
So on desktop, you are or are not able to keep the browser open long enough to visit websites?

Hi, I am unable to start Brave Browser at all on my new Macbook Air. The OS is Monterey 12.0.1 and it’s an M1 chip.

My Brave Browser works fine on my older Surface go and I wanted to continue using the browser when I switched over to my Mac. Beta version also does not work and will not open without crashing.

I’ve been having this issue for the past few days, and so have been using Edge as the only other browser on my computer. This evening, though, as I attempted to place an online order, Edge blocked me and said I needed “permission from an adult” to do so. I checked my settings and couldn’t figure out what they were talking about, so downloaded Chrome, just to realize that was also crashing, in the same way that Brave was.

Long story short, apparently with this latest Windows update my Microsoft account was automatically added to a “family,” which automatically turned on web and search filters. I noticed when I looked into them those filters block any browsers other than Edge. As part of a “family” there is no way (that I could find) to turn off search filters, other than removing myself from a family. Once I did that and restarted my computer, Brave (and Chrome) are working again.

So, FYI, Microsoft is blocking all browsers other than Edge. Hope this helps someone else.