Brave Browser: Can't click anything after new Mac update

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
How can this issue be reproduced?

  1. Open Brave Browser
  2. Click on anything (any buttons on website, menus on browser, address, etc)
  3. Cannot click and it doesn’t show any signs of being clicked. (looks unclickable), including links when using Google search engine.
  4. Restart Brave Browser or Restart Computer. Everything repeats.

Expected result: Should be able to click buttons on Browser…

Brave Version( check About Brave): Whatever the latest version is. Cannot click on it at the moment.

Additional Information: update*I use most of my browsers in full screen mode. It seems to solve the issue once out of full screen… And the issue comes back once in full screen.


Same. Can’t click in the url, open new pages, etc. Sometimes it works fine but after the while it doesn’t.

1 Like

Same issue here. When exit fullscreen, it works! Intermitted issue. So annoying

1 Like

Same for me. On full screen on my mac I can not click on anything from the middle to the top of the screen

Same issue only on full screen on my mac

Same issue any workaround to fix (Downgrading the brave update ??)

Same issue here, let me paste my report as well.

Description of the issue: Brave UI and website elements are not clickable in fullscreen mode.

How can this issue be reproduced?

  1. Open Brave Browser on MacOS Ventura 13.6 (22G120)
  2. Go fullscreen
  3. Click on an address bar or interactive website element placed in top.

Expected result: Clickable Brave UI and website elements.

Actual result: Brave UI and to website elements are not clickable.

Brave Version( check About Brave): Version 1.59.117 Chromium: 118.0.5993.70 (Official Build) (x86_64)

Additional Information: It works fine when not in full screen. When in fullscreen it looks like top-center area on the screen is not clickable.

1 Like

Same here, wanted to create a post about here, but couldn’t click on “new post button”.

Happy to learn the quickfix is to disable full screen, but since I’m always in full screen, I’m hoping for a fix in the next scheduled release.

Keep up the good work :slight_smile:


I’m also having this issue for the last few days, absolute hell, I thought my mouse was going bad, but it’s Brave, switching off Full screen really seems to work around it.
Please fix this, I work full screen 99% of the time.

Brave version v1.59.120
Mac M1 Ventura 13.5.2

1 Like

same for me. Super frustrating, affecting my work.

1 Like

@cidus @ftsang79 @fbnv @quarties @iamkunal9 and everyone else (nearing limit on how many I can tag, so yeah…)

Can all of you check to see if you have Memory Saver enabled?

I was checking Github and I found a related topic. In it, they discovered turning off Memory Saver solved it. I just want to see if this is the same for all of you or if this is a different bug/issue.

But as going through, I also know they have another open at and not sure how many others. Ideally though, going to need to try to grab more details on how big of areas can’t be clicked on, what you have enabled, if there’s any changes made at brave://flags, etc.

1 Like

yes, I had memory saver enabled. I disabled it to see if it resolves the issues. Will report back soon. thx for the tip.

1 Like

Memory saver was off for me.

As for the area, it’s hard to pinpoint but I think it mostly happens at the top third of the screen.

Menus, search bars, that kind of thing.

Ok, so I think yours is related to that second Github link I provided. Up to you if you want to check it out. I think it’s something still being investigated.

1 Like

So after I turned off Memory Saver, turned it back on immediately, and then restarted the Brave - all works like before! And it keeps working after restarts :slight_smile: Thanks a ton for that <3 Later, just to be sure, I changed all flags to default (but I’m pretty sure I never changed those).

In my case, the unclickable area was something like 1/3 of screen height starting a bit from the top edge of the screen (so I could change tabs if I really wanted to, as a small top part of the tab was clickable), and bout 80-90% of the screen width centered (I could click some UI elements on left/right edge in the top 1/3 of the screen, but closer to the middle it was unclickable again).

EDIT: And it stopped working after ~3-4h :confused: I had to restart the browser, and disable Memory Saver again.

Hello @Saoiray, thanks for the input.

Memory saver setting was turned on for me too. Regarding the areas that can’t be clicked, I’d say top third as well, but also other buttons on web pages (e.g. the New Topic button on which is rather at the center of the screen). Also had problems scrolling, it was like the page froze, and refreshing it didn’t help.

However, I just tried @quarties’s fix, and it seems to have solved the problem, thanks :slight_smile: ! Will edit if I encounter any further issues.

@steeven @Mattches Can you two check into this a bit more? And not sure between the two Github that I found, which is better to have active on this based on explanations people have given. Heck, perhaps I should dive deeper and there could be more open Github. Regardless, hoping to get it in the right eyes and try to have the bug figured out.

Looks like both of these issues are applicable. Issue also appears to be specific to Ventura as that seems to be what everyone reporting this is using (at least anyone who told us the OS version). I’m on Sonoma 14.0 and do not have this issue.

Reaching out to macOS team to make sure we get more eyes on this asap.

1 Like

Im on MacOS Sonoma but Im facing the same issue.

MacOS: Sonoma 14.0
Device: MacBook pro
Chip: M2
Display: 13.3-inch

So this has happened to me and I have come to the conclusion that there is a dead zone in the browser where you cannot click anything at all (middle part mostly) corners work up until around 1/4 in the browser screen that when it does not register. Exiting the browser and working not in full screen works but it is a massive inconvenience