Brave Blocks YouTube Thumbnails

Hello! I’m using Brave with it’s default settings. I’ve never added any additional configuration

All right, could you please provide a screenshot of Brave Shields after you open YouTube?

Open YouTube → click on the Brave Shields icon in the address bar → click on Advanced View (if it’s not in this view already) → take a screenshot.

There it is. Now I notice that it also blocks user images…

Thank you for the provided screenshot. Could you please check whether YouTube works normally in a private window without any extensions?

The same thing happens.

That’s very weird. Could you please check whether this issue persists in a fresh user profile?

I want to determine whether the issue is related to your current user profile in some way. If it turns out there is an issue with your current user profile, we’ll try to fix it, I don’t want you to give up on the user profile.

: (

Same problem

Thank you for checking. There is definitely something wrong, I’ll tag Brave’s Filterlist Engineer so he could take a look whenever he can.

@fanboynz

Thinking whether this issue could be related to the cookies regression issue.

Ok! I’ll wait for his reply. Thank you Rethanis for the support :hugs:

1 Like

Just a suggestion. it will mostly not solve your problem but worth a try.

Go to settings and search for Hardware Acceleration and turn it off and see if it solves the issue.

1 Like

No matter how unlikely it is, disabling Hardware Acceleration has worked wonders for variety of issues, suggesting that isn’t a mistake most of the time.

What I find particularly interesting in this case, is that disabling Brave Shields resolves the issue, which makes me think it could be related to a regression issue with cookies that @fanboynz reported, as disabling Brave Shields allows all cookies - which could be resolving the issue. I can’t reproduce OP’s issue so can’t tell anything as of the moment, unfortunately.

1 Like

I also cannot reproduce this but my first suggestion would definitely be to check and see if disabling Hardware Acceleration and see if this resolves the issue.
You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

I disabled the Hardware Acceleration and the issue persist.
No thumbnails or channel/user avatar are displayed.

Hmm, that’s weird.

Until the problem is fixed, I suggest you to switch off the shields for YouTube and install a Extension that blocks YouTube ads.

@Diani414

Could you check the following:

  1. Open YouTube.
  2. Click on the Brave Shields icon in the address bar.
  3. Change Cross-site cookies blocked to Allow all cookies.

I have my doubts that the issue is related to a regression issue with cookies.

Its quite a common issue, just googling “youtube thumbnails not showing” gets a few results.

I would try the following:

brave://settings/clearBrowserData (Clear Cookies/Site data)
brave://net-internals/#dns (Clear)
brave://net-internals/#sockets Select Close idle sockets, and click Flush socket pools

Then restart the browser.

Hello

None of the solutions worked.

@Diani414

Allowing cookies didn’t work?

Could you please open brave://adblock and check whether any filter list is selected and whether you’re using some custom filters in the textbox at the bottom of the page. You might have accidentally blocked an element, which will appear as an entry in the Custom Filters textbox at the bottom of the page.

So far I can’t understand how disabling Brave Shields resolves your issue.

This is unbelivable. Aparently I had a custom filter activated (!!!)
But I’ve never seen this page before. And, as I said earlier, I always used Brave with default settings. I am really surprised by this. I’ll clear everything and see what happens.

1 Like

Finally! I can see every thumbnail and image perfectly!!
Thanks to everyone and specially to @Rethanis for helping me with this issue!

3 Likes