Brave beta (MacOS) crashes upon open

Still doesn’t work for me.
Downloaded Chrome, installed and runs perfect.
Downloaded Brave Latest Release, Beta and Nightly. None works for me. Always crashes upon open.
On the other hand I don’t have a Brave Folder under Application Support.

same. brave apps aren’t working for me withwe

@ZiG-ZaG @AOindian28,
Can you both confirm for me that, when installing the browser, did you drag the Brave icon into the Applications folder when prompted to do so?

yes, confirmed. the same like I did with chrome for example.

1 Like

I don’t know what you are saying, but I didn’t do that. I don’t even know where the applications folder is…

@Mattches @ZiG-ZaG There is one way you could get brave to work. So, I tried to rename the Brave exe file to something random like ss and it worked for me. You can’t see the icon anymore when you open it tho. But that’s fine

My Brave Program is called Brave.app, you are talking about this one? I changed the name from that but still doesn’t work.

What i did was i went to the search bar and searched brave, then i right clicked on it and went to open file location. I got sent to file explorer and i pressed open file location again and then i saw Brave and then a red lion icon. I clicked on rename and changed the name to ss

@ZiG-ZaG@AOindian28 is on a Windows machine, where as you appear to be on a macOS machine so the fix they are referring to will not work for you. I have pinged the appropriate team members to take another look at your situation in order to see what needs to be done to be reesolved

1 Like

Just updated to MacOS 12.2 and no changes.
Downloaded and installed actual Brave Release Version, Beta Version and Nightly Version. Still crashes after try to open.

I’m having the same problem, but with all versions of Brave. The release version, beta, and nightly. I’m on an M1 Big Sur 11.6.2. Browser crashes upon opening. I’ve checked the stated directories above and did not see a folder for brave. I am running the latest version of Brave. Been having this problem since December. Been trying the new versions every time they come out.

ok, so same like here. why we have no brave folder???

I have the same problem. I download Brave Browser for MacOS (M1 version), and the browser won’t open. Crashes every time. I am on the latest version of Monterey (12.2).

1 Like

Brave Release works fine, Brave Beta won’t open and crash (freshly downloaded)

I’m on Mac OS 10.11.6

Still not working and none of the suggested solutions work.

@AOindian28

Mac OS directories

Root: simply a forward slash /

Root and System level folders

/
/Applications/
/Library/
/System/
/Users/

The “Brave Browser.app” application is located:

/Applications/Brave Browser/

There, and hereafter, I am referring to the location of files and folders - assuming that a recent, stable release of Brave Browser is the only installed version. (No Beta’s. No Nightlies.)


Your machine user account folder, aka home folder “your_username_aka_shortname”:

/Users/your_username_aka_shortname/

Therein (of interest today):

/Users/your_username_aka_shortname/Desktop/
/Users/your_username_aka_shortname/Library/

Your user account’s Application Support:

/Users/your_username_aka_shortname/Library/Application Support/

has a Brave Browser folder named “BraveSoftware” therein:

/Users/your_username_aka_shortname/Library/Application Support/BraveSoftware/

And therein, a sub-folder “Brave-Browser”:

/Users/your_username_aka_shortname/Library/Application Support/BraveSoftware/Brave-Browser/

And, therein, several files and folders.

Please have a look here, this solved my issue:

1 Like

ZiG-ZaG,

Thanks.

Not working, this is abysmal.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.