Brave beta (MacOS) crashes upon open

Brave beta crashes on open. Everytime. I installed a fresh version. Still occurs. Started about an hour ago.

Description of the issue:
How can this issue be reproduced?

  1. Brave beta is crashing upon open every time. I restarted device and reinstalled a new beta. I can’t open and use beta.

Expected result: Should stay open

Brave Version( check About Brave): I can’t check if I can’t open, but I check and install any updates every day.

Additional Information: I started using Brave beta because of a regular browser bug that no longer gives me BAT despite having ads turned on and seeing ads. I get BAT in beta. No big deal, as I don’t care that much about BAT, but if I can’t use beta, what’s the point? Please fix this. It started about an hour ago.

@Mattches any troubleshooting I can do? I’m lost here.

Also, just tried downloading Brave browser nightly and it crashes upon opening also. What gives?

Sorry for the long wait time here.
When you downloaded the browser (any version), were you sure to select the right chip-type for macOS? There is a different option for macs with M1 chips than there is with Intel chips.

Yes, I was absolutely sure. I’m rocking MacOS 10.13.6, so downloaded Intel, but Brave is supposed to support versions this old. I’ve tried everything obvious. To update, I just tried again to download Brave beta and Brave Nightly and still can’t open either. I hadn’t tried in almost a week, so I don’t know what’s going on.

Have you tried the release version of the browser? Do you get the same results there as well?

I just did. I downloaded a second copy. Didn’t want to uninstall and risk not being able to use Brave at all. It downloaded and works fine, even has my extensions already installed. Please keep troubleshooting with me. I am baffled why it just stopped working one day.

Wait so the Release version works just fine but Beta/Nightly don’t work – correct? Is there any particular reason you want/need to use the Beta over release build?

Yes, for some reason, Brave release version no longer gives me BAT despite having ads turned on and seeing ads. I was able to get BAT in beta. I used beta for months because of this. I’ve Googled and seen many similar posts about this and it apparently hasn’t been fixed, so I figured I’d just give it more time. But now, I can’t receive BAT. I consider that a separate issue than the beta crashing problem.

I’m having the same problem also, I’ve also reinstalled & it just keeps crashing.
Release version works fine.
No reason for me to be using the Beta version other than I like the blue icon. :slightly_smiling_face:

Still waiting on some assistance for this issue as I am unclear as to why Stable would be running just fine but Beta would not.

@Lenny can you please tell me what version of macOS you’re using when you see this issue?

I’m running High Sierra 10.13.6

Oh lookie, we are both running the same version…

For either of you, are you able to keep the browser open long enough to go to brave://crashes and send us the crash report? If automatic crash reporting is enabled, does it stay open long enough to visit that page and share the crash report ID with us?

No, it crashes before it opens. I get this window every time. (I whited out the user ID and Anonymous UUID, whatever those are, as I wasn’t sure that is something that should be public). I was going to copy and paste the full text in a reply, but it was too many characters. This is for the Brave beta browser.

Same OS version. Interesting. Has this been occurring for you also since Dec 21st? I know exactly when it started, because I use the Browser all day and all of a sudden it stopped working. Not sure if it updated in the background or what.

Plus, the blue icon is all the reason you need. :wink:

It crashes before any window can open.

Can you suggest a way (or give us a link to instructions) for us to be able to send you an entire crash report that we can see?

I think mine started on Dec. 27.

I had closed it 2 window open, one with 4 tabs open & the other :roll_eyes: with probably ehh, 50 something tabs open- to use the release version to pay a bill. After that it wouldn’t open, my thought was it was just to memory packed to open. I re-downloaded & still had the same problem. I put it in the trash, emptied it & repeated the download only to find it still wouldn’t open.

Can you two try opening the macOS Terminal running the following command:

ls -la ~/Library/Application\ Support/BraveSoftware/

This will show what permissions these directories have – while I’m not convinced this is the case, it’s certainly worth checking either way. Please send a screenshot of the output after running the command as I’ve shown below:

It comes back “command not found”.

Hmm – if you open finder and go to

~Users/[Your user name]/Library/Application Support/

Do you see a Brave Software folder here?