Brave ads showing but not getting bat token on laptop

Please ensure that you’ve read through the following topics/pages thoroughly before opening a topic as your question may have already been answered:

Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Briefly describe your issue:

What Operating System and Brave version are you using (Menu --> About Brave)?

Is your browser wallet currently verified? (yes/no)
yes

What date did you verify your wallet?

Have you been able to successfully receive payments in the past?
yes

Are you using a VPN? (yes/no)
no

Are you in a supported region (see here for list of supported regions)?
yes
Does your device pass the SafteyNet check (Android only)?

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??

Briefly describe your issue:

Ads WORK, but no Brave Reward! Repeat Ads work, but no reward. Brave Browser STOPPED giving rewards for me in March 2020 on my MacBook laptop. I switched to Brave BETA and it worked and I have received rewards ever since. This past week, Brave BETA stopped giving rewards. The amount froze. So, today, I downloaded the latest Brave Browser ( not beta) and rewards do not increment, they stay at zero while ads continue to display. Ads display as expected, but the rewards do not increment.

My previous bug report the team was focused on Ads. This is not about Ads.

What Operating System and Brave version are you using ( Menu --> About Brave )?
Mac OS Big Sur 11.6
Version 1.33.77 Chromium: 96.0.4664.35 (Official Build) beta (x86_64)
](https://brave.com/latest/)

Is your browser wallet currently verified? (yes/no)
yes

What date did you verify your wallet?
Couple months ago.

Have you been able to successfully receive payments in the past?
yes

Are you using a VPN? (yes/no)
no

Are you in a supported region (see here for list of supported regions)?
yes

Does your device pass the SafteyNet check (Android only)?
Not applicable

Have you manually turned off Auto-contribute on all of your devices linked to Uphold??
Yes

Your help is appreciated. Thank you.