Brave Ads Windows 10 Troubleshooting

Given the many reports received of Ad notifications not appearing for some users, we’ve compiled a short list of [Windows] settings to check to ensure that the Ads platform and your OS play nicely together.

In this thread – please let us know if any of these steps resolved the issue for you (and if so, which ones?).

Check OS notification settings

Windows 10 has specific notification toggle switches that can be enabled and disabled across all applications, and for individual applications.
From the Windows 10 operating system Settings image

  1. Select System
  2. Select Notifications & actions from the menu options
  3. Make sure that Get notifications from apps and senders toggle switch is in the On position.
  4. Scroll down, and make sure that the toggle switch for notifications from Brave is in the On position.
  5. Also scroll down to check and ensure that the Focus Assist notification toggle is also in the On position.

Unable to Enable Notifications

In some cases, users may find that they are not able to enable notifications from applications. The option for doing so may appear to be disabled (pictured below).

In this case, it is likely that notifications are blocked by a Group Policy. If the user is part of a company or school network, they may need to speak to the IT department.

One potential workaround is to manually override the registry entry, allowing notifications. Within Windows’ Registry Editor, navigate to the following path:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\PushNotifications

If this path does not exist, refer back to the IT department. If the path does exist, you should find a key by the name of NoToastApplicationNotification. This key will likely have a value of 1. Changing this value to 0, then restarting the device, should allow you to enable notifications for applications.

Check OS Focus Assist Settings

Focus assist is a feature of Windows 10 for managing when and how notifications will be displayed on your machine. It’s essentially a “do not disturb” mode that may be blocking notifications from showing on your end.

If Focus Assist is scheduled or configured to disable all notifications, users may not see notifications.

  1. In Windows, click start and type Settings in the search to find the OS System( image)
  2. Select Focus Assist.
  3. To disable Focus Assist, select the Off option.
  4. Check to ensure that the Automatic Rules settings do not have During these times scheduling enabled.

Of course, you can take advantage of the Focus Assist settings, and also view Brave Ads. Here is how you can configure your settings to enjoy both:

  1. From within the Focus Assist settings, select Priority Only or Alarms Only.
  2. Check to make sure that During these times scheduling is disabled.
  3. Check to make sure that the box for Show me a summary of what I missed when Focus Assist was on is checked.

See Brave Ads that served while Focus Assist was enabled

When Focus Assist is enabled and the Show me a summary of what I missed while focus assist was on setting is enabled, Brave Ads notifications that you missed while you had Focus Assist enabled will remain in the System Notification Center for you to revisit at your leisure.

To access, click on the Notification Center icon in the lower right corner of the Windows task bar.
image

2 Likes

Hi! I just started using Brave and it works great when I enter a website in the address bar. I followed the directions for import bookmarks and tried all the selections but I still don’t seem to have any? I checked all the settings above and those were already correct.

There is no star on the address bar or next to it? I have Win 10 home v 1809 build 17763.437 on a desktop. Should this have been in a new topic?

Thanks!

Hey, thank you very much for those informations.

My notifications were disabled so i changed it. But i have another issue ^^ Apps don’t appear in the menu after i activated notifications for every apps. Focus assist is off.

Hope you can help me with this. Thank you

2 Likes

Ok to let you know i ve just found a way… when i wrote my message at the top of the page it was asked something like “Do you want to be notified when someone answers to you?” i pushed yes and Tada it appeared on my notification :star_struck::joy:

1 Like

I do not see brave in my notifications options.

2 Likes

Notification options are correct.

any help for this issue?

seems i have exactly the same problem 21 ads no change no nothing and adds have stopped, whats the deal admin??

just found out you can only get 21 ads per day, first ive heard of it so it obviously clearly stated…

Same issue. Brave is not in the notifications&action list to turn it on. How to add brave in Notifications&action to turn this option on???

1 Like

Me too, do you find a solution ?

@chrisper,
Is Brave set to be your default browser?

1 Like

Yes it is. I tried so many things for hours. I think it has something to do with the notification. Still is not showing me any ads

@Chrisper,
Can you try changing your default browser to Edge or IE (or anything), then back to Brave and see if it appears in the Get notifications from these senders list?

I have the same issue as @Chrisper and others. Brave is my default browser. I have notifications set to “on” and focus assist set to “disabled”. But Brave does not appear in my available apps for notifications. I tried to change the regedit but the path for Push Notifications does not appear. But this is a personal computer and I have no IT department to consult (I wish!) - any advice?

It looks like this issue is known @kintsugi @Chrisper – I actually haven’t seen this before. I’m unable to reproduce the issue on my end, but we do have a Github issue open for it – I’ve added your report to the thread here as well:

1 Like

Update: this issue was fixed for me, I am receiving notifications now.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.