Brave 1.18.75 and RAM issue

Last night Brave ate more than 3GB and froze my laptop. Today the browser ate about 2GB and almost froze my laptop again. I think this is an 1.18.75 issue. I still use Windows7 x64. Does anyone have the same problem?

How can this issue be reproduced?

  1. I just opened YandexToloka, Instagram YouTube subscribe and an YouTube video.
  2. Than I noticed lags, check Task Manager and saw that one of Brave’s process ate about 3GB RAM.
  3. When I closed the browser, several process were active about a few minutes.

Brave Versio: 1.18.75

Additional Information: Windows7 x64

2 Likes

Hello @NotDeveloper

go to brave://settings/system

make sure this off Continue running background apps when Brave is closed

restart brave and see if it get better if not ? disable all extension and try in private mode

1 Like

This is different thinks.
The browser was dead, so these processes continued to work.
This is some kind of RAM leak in the last released update.

Same issue, Win10, Brave v 1.18.75. Started 12/13/20, Several other threads about this issue.

Could you give me links?



1 Like

@NotDeveloper as you like

Works fine for a bit, then just continues chewing up memory/cpu and then crashes.

which step you used just disabled the running in background or disable extension and use private mode?

Running in background didn’t make a difference, but disabling extensions seems to help some. I only had two anyway.

what about using private mode

or even create new profile

or last but not least try the following

close brave and try this

use this flag -user-data-dir instead of the --incognito which given in the link
it will start brave as new profile

if any step was enough then do not try the other one and let me know maybe the issue in the profile or your cache/cookies

Sorry, none of this is helping. Gets to about 8 tabs and locks up. I thought the disabling extensions helped, but it didn’t. Tried the private mode and the flag. Still locking up

do not be sorry
sorry the flag is --user-data-dir i missed one -

did you tried the new profile or not?

Yes, I used the “–user-data-dir” . No help. Here’s the app usage with 8 tabs.

what about disable the reward and restart brave

They were already disabled.

not sure what could be the issue so let me ask one of the team @Mattches to help you

please notice it still week end so it will take time to get response

and have a nice day both of you

Thank you very much! Have a nice weekend.

you very welcome and thanks a lot :slight_smile:

UDP:
The same issue on Vivaldi. So it may be:

  • Chromium bug
  • Website bug
  • Extension bug
  • Some technology used on website or extension bug