Brand new to Brave and cant figure out how to stop this from showing up

Hello, like I said im brand new and know nothing! I have "Clear all browsing data on exit" checked, and im guessing that is a factor, I unchecked the shield box, but I cant get this to stop showing up every time I visit the page! Any help would be greatly appreciated

Does it stop happening if you turn of the ‘clear all browsing data on exit’ setting?

FB likely won’t “know” if you consented if you keep effectively erasing your identity by having their cookies be deleted.

Not necessarily a permanent fix for whatever you’re ultimately trying to do, but at least let’s see if we can establish this as the cause.

@ReallyFrustrated Hey. Let me actually ask you really quick:

If you go to Shields in your settings, then to filters, do you have any turned on? Quick way to get to it is brave://settings/shields/filters.

If not, make sure you have Fanboy Annoyances List and uBlock Annoyances List turned on. They will help a lot, not only with ads but in eliminating cookie notices like you’re seeing. If you don’t want those particular filters on, then at least make sure Easylist-Cookie List -Filter Obtrusive Cookie Notices is turned on (You don’t need it active if you have Fanboy Annoyances on).

you keep deleting the cookies when you exit so there’s no problem to that. But when you visit the site again it will ask you to enable those cookies for the first time

Can’t block the facebook/instagram consents without causing issues. For the sake of webcompat it has to stay to avoid breakages.

So that mean a person has to whitelist it and permanently let them have cookie access in order to prevent it from reappearing every time you go to clear?

Also, cookies still would be blocked from tracking and would only be for 1p usage, right?