Binance Pegged SHIBA INU wont show

I expected them to simply show in my wallet to the address Brave gave me to copy/paste. The tokens originally showed in the wallet on my computer after I sent them from binance. So they WERE there.

After the transaction initially showed up with no issues I proceeded to import my solana account to the Brave wallet. It all showed good. I went to bed. Next morning when I logged in to do something I noticed BOTH SOLANA account and SHIB were 0 balance. This is when I imported the wallet to my mobile phone via seed phrase.
When I imported it to my mobile the Shib token wasnt showing at all which is when I proceeded to add it but has always showed 0 balance since import. I began fearing I had been hacked somehow and had my account drained, but since then its not looking that way.

As you can see my solana account is still there, Shib no.

This is the wallet address on my PC wallet: 0xE8824d6B210605E5Db9e3556ADdC536A87caA11f

This is the wallet address on my mobile phone browser wallet: 0xE8824d6B210605E5Db9e3556ADdC536A87caA11f

Here is the transaction from Binance to Brave : https://bscscan.com/token/0x2859e4544c4bb03966803b044a93563bd2d0dd4d?a=0x076188eC5dbF6341F0ad307EcE3d1CD740d5C170

I didnt notice the difference in ETH address on the wallets compared to the transaction until a while after this glitch and looking over everything trying to figure out whats going on.

This address to send to I got from the Brave wallet to copy paste into the transaction. 100% exact steps I took are now getting a bit fuzzy to recall as time goes on.

I imported the wallet from a 24 word phrase. I only have the one seed phrase.
This seed phrase was generated by Brave wallet on my PC
Brave Wallet Recovery
Date created: 2/20/2020

I have never actually used the wallet for transacting until this Shib transfer. As I have generally stuck to exchanges I never had a use for the wallet. I had intentions of staking my Shib which is why I transferred to wallet and chose to try out Brave. I have only ever imported my wallet with this phrase. Have not knowingly created new account/address within Brave.

It was sent using BEP-20 as the network chosen.

I had 0 balance in the Brave wallet when I sent from Binance.

The other strange anomoly is that this Solana account shows on my mobile wallet but not on my desktop version. There is a bit of a difference between the layout of Brave interface on my phone and computer. I dont know if this is normal or not.

So the reason that these assets aren’t showing up then is because they don’t belong to an address being managed by your wallet currently.

Do you still have the keys associated with the wallet address 0x076188eC5dbF6341F0ad307EcE3d1CD740d5C170?

From my end, it’s not clear where you would have gotten this wallet address from but it doesn’t seem to have appeared out of thin air. It may be a second or third wallet address that can be derived from your seed phrase and when you imported your Solana account it may have reset your wallet with so the additional addresses didn’t get automatically detected.

If all of your assets are from the same seed phrase it should be possible to regenerate the other HD accounts by visiting brave://wallet/crypto/accounts/add-account/create/ on desktop. You can also find this in the UI, by going to brave://wallet, selecting accounts tab, and clicking the plus button in the top right corner to create account. From there you’ll select Ethereum (or Solana) and it should generate the next HD account. If that wallet address matches your assets should appear.

The other aspect that may be at play here is that when you go to import a 24 word seed phrase there’s two paths that have been supported by wallets throughout the ecosystem for these longer seed phrase. When you’re importing the seed phrase to Brave Wallet, it’s possible to import just the 24 word seed phrase or to import it with “Legacy” mode by checking the box. If you originally generated your account with Legacy mode then you should be able to re-import the seed phrase and check the box like so:

All in all, it doesn’t appear that you’ve been hacked or that this seed phrase has been stolen. If that were the case, the funds wouldn’t still be sitting in the address you linked to still. Wallet drainers and seed phrase stealers will move the assets out of the account as soon as possible which would mean there’s an additional transaction from that account. In this case, it looks like you just need to get the private key associated with 0x076188eC5dbF6341F0ad307EcE3d1CD740d5C170 into your wallet so that you can manage the funds with your Brave Wallet.

With the seed phrase I have never seen an option regarding legacy wallets. This is from desktop.

I have a Private Key that was generated for the Solana wallet. On my mobile phone this is showing with no problem.

I have a Private Key that was generated for the Ethereum.

On desktop the Solana address is not visible at all since the glitch. This is it showing on my mobile phone.

If I try to import Solana address from the Private key that I can see on my mobile phone to the desktop I get the following error
“Cannot convert string to buffer. toBuffer only supports 0x-prefixed hex strings and this string was given: 0x Private key is here”

Any time I try to restore from the Ethereum key, it tells me that I’m trying to import a duplicate account.

I created 2 new addresses now following your instructions with no luck in viewing my SHIB. The addresses did not match with 0x076188eC5dbF6341F0ad307EcE3d1CD740d5C170, both entirely different. I added SHIB to both and still no SHIB showing.

I then proceeded to try import from seed phrase again to which BOTH of those new addresses have disappeared.

It does not give any option for Solana.

The way that these 2 new addresses were generated, I know I did not create a new Ethereum account within the wallet when I transferred the SHIB. I got the address I transferred to from the deposit button next to Shiba Inu Token in the list. I pasted this into Binance. It all went well initially and showed up as Binance-Pegged Shiba Inu. There is nothing I can find on the desktop to re-ad Binance-Pegged Shiba.

I’m beginning to feel somewhat defeated at this stage and losing hope that the Brave wallet hasn’t screwed me over.

Let’s take a step back here a second because some of the details you’re sharing suggest we’re not on the same page.

First can you answer just these questions for me:

  1. Do you have one or multiple seed phrases?

  2. Are they all backed up?

  3. Do you also have separate private keys?

  4. If so, how did you get them and are they backed up?

Once I’ve got the answer to these we’ll figure out the next steps.

1. Do you have one or multiple seed phrases?
I have 1 seed phrase for the Brave wallet. It is a 24 word seed phrase.

2. Are they all backed up?

Yes, this is the one that has been backed up since 2020.

3. Do you also have separate private keys?

Yes I have 2. One for the Ethereum account and 1 for the Solana account that I imported from Phantom wallet.

4. If so, how did you get them and are they backed up?

I got them both from Brave wallet via export private key. Originally via the desktop in the following area

Both accounts are still accessible on Brave mobile wallet and both of these Private keys match what I have saved.

My Solana assets are still accessible still via my Phantom Wallet - same private key is in Phantom Wallet and Brave Wallet for this account.

Yes they are backed up. I put both Private Keys and the addresses in the same text pads that I keep my seed phrase. I keep 3 copies on separate devices. I saved these 2 keys the night I transferred SHIB and imported the Solana wallet.

When I tried to import the Solana account back to desktop via the Private Key given I get the error
“Cannot convert string to buffer. toBuffer only supports 0x-prefixed hex strings and this string was given: 0x Private key is here”

My Solana assets are still accessible still via my Phantom Wallet - same private key is in Phantom Wallet and Brave Wallet for this account.

Thank you so much for your time trying to figure this out.

I would create a few more ETH addresses in the wallet and pay attention to the string of each newly created address for the one that matches the transaction.

Ok, this is very helpful. Since you’ve got your seed phrase and private keys backed up let’s have you do this.

  1. Download Brave Nightly
  2. Restore your wallet in the Nightly browser using the seed phrase, and check that legacy box.
  3. Import both your Ethereum Key and your Solana Key into the wallet
  4. Add some additional accounts via the + button in the accounts panel after you’ve imported the private keys.

See if the account appears (and the assets) doing this. If it doesn’t, try resetting the wallet in Nightly in brave://settings/web3 and retry without checking the legacy seed phrase button.

Let me know if you encounter any errors and which wallet addresses appear when you do this as well.

1 Like

I was almost bummed when it didn’t work with the legacy seed option ticked so tried again with it not ticked and

Massive sigh of relief! Happy dance! Cheers of joy!

You are an absolute legend!!!

Thank you so much for your time and help with this. Also to @Soiray for his efforts helping and bringing it attention.

I have so much gratitude for you both right now!

:star_struck: :heart_hands: :partying_face: :heart_hands: :star_struck:

2 Likes

You are most welcome! Glad we were able to get it solved. Also, what this means is that somehow your wallet got stuck in a weird state and it may have been a bug but at the very least it’s now been fixed and will be incoming to the stable version of Brave (with the orange logo).

If you reset your wallet on Brave Stable and import in the same way you did without the legacy box ticked, it should work in Brave like normal. If it doesn’t then it was a bug that will be fixed once the code in nightly stabilizes into Brave Stable. Unfortunately sometimes bugs make their way through or data on the filesystem can be corrupted in ways we can’t reproduce, so I appreciate your patience in working with me to test things out to fix it.

2 Likes