BAT disappeared when I linked Gemini account

I linked my Gemini account and a year’s worth of BAT disappeared.

Windows 10
Version 1.31.91 Chromium: 95.0.4638.69 (Official Build) (64-bit)

Yes, browser wallet is currently verified?

14/11/2021

Yes

No VPN

Australia

Yes

Yes

1 Like

exactly same thing happened with me

2 Likes

You are not supposed to post that info here…
You have to send it to the support via DM.
Also your Wallet ID is missing.

I don’t know where to directly contact them.

Read other threads and find them =)
Not going to do the work for you

rude, very sad reply

2 Likes

Same thing happened to me! Hope a fix is found soon!

Same thing happened here just now

Same happened to me, everything is magically gone right after gemini wallet link.

Gemini is like … uphold is better

Same thing happened to me right now.

This is a very common issue, It happens way too often. The Moderators are very slow to respond and haven’t addressed the issue yet. It’s a joke really. I’m currently in talks with one of the mods and they are asking me for some information taking days to respond to me at times. I’ll keep you guys in touch.

3 Likes

Thanks dude. This is getting ridiculous. So many people are missing rewards and I have been using Brave for 2.5 years, all that BAT has just disappeared.

It happened to me as well. I’ve lost the BAT I received before verifying with Gemini, but I managed to receive those earned on October. I’ve also tried to answer on another thread, but the mod closed it saying that payments were still pending. However, it’s been more than 20 days that I verified my wallet.

Can the mods please help us with this problem?

@Neichello have some patience! I had to wait about 1,5 - 2 weeks too. But they solved my problem.

I guess it’s due to them having a small support team. So with people asking the same questions couple hundred times without looking up active or older threads with the exact problem, it just takes longer.