Aw Snap! Brave not loading any page

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
How can this issue be reproduced?

  1. Brave is perfectly loading pages and set up to start up from where it left off
  2. Closed the browser
  3. Restarted the computer (Windows 10)

Expected result:
Once opening the browser it should re open all closed tabs and load them up

Brave Version( check About Brave):
The latest one available (download 2019-10-27)

Additional Information:
Out of the blue it stopped working following a restart of the computer. Cannot access settings or clear cache, bookmarks…nothing…

  • Did not install any new spyware, antivirus but just in case added the app as an exception. NO LUCK
  • Removed Brave directory’s contents in app in C:\Users\user\AppData\Local\BraveSoftware.
    Restart the comptuter. NO LUCK
  • Uninstall Brave, restart computer, installed the latest version. NO LUCK
  • Tried the incognito mode. NO LUCK
  • Tried to add -disable-gpu. NO LUCK

Really disappointing and concerning, can’t even back up bookmarks…

Please help or suggestions?

Related links used:

1 Like

may it help

Functioning workaround:

  • Open brave in Windows 8 compatibility mode (right click on brave.exe> properties > compatibility tab)

Hope there will be a fix or root cause soon


This started for me on Thursday, 10-24-2019. Cannot load any pages or adjust settings. The only screen I get is the “Aw, Snap” page. Uninstalled, reinstalled, no change. Reboot-no change. Simply will not run. Using Windows 10 on a Microsoft Surface Pro4.

Windows 10.
Brave 0.70.121
Chromium: 78.0.3904.70 Official Build (64-bit)

Everything in Brave is “Aw, Snap!”
Can’t access settings. Can’t access anything as it all tries to load in the browser, which shows “aw, snap”

Running in Windows 8 Compatibility is a functioning, temporary workaround.

1 Like

YES - This solution worked for me!

Brave load failure seemed to occur after using a program with an extension (that updated in background).

It was a good reminder to BACKUP bookmarks and settings because those functions were DOA with load fail.

Thanks Patrick!

Changing to Windows 8 compatibility mode fixed it. I believe my extensions from Duck Duck Go and Citrix were the problem. I would get message blocks indicating the extensions failed to load, click this balloon to reload extension. It would just continue to fault.

Can confirm this. Uninstalling and reinstalling the browser does nothing. Deleting the appdata folder before reinstalling does nothing. This occurred as a result of whatever update that dropped on 24 October.

This is one reason why offline installers are a good idea.

Note that we do have offline installers available on our Github page.

Oh, sorry. I just read a thread from last year marking them as backlog. Thanks for letting me know.

1 Like

I am having the same issue and setting it to windows 8 compatibility fixes the problem. Please fix whatever is causing this issue.


Used the offline installer, it ran, then something, either my antivirus or something updated and it started doing it again. The windows 8 compatibility mode seems to work for now.

This topic was automatically closed after 30 days. New replies are no longer allowed.