Auto-Contribute turning itself on without my consent causing me to lose all my ~20 BAT?


Description of the issue:
So, I go to the “Claim monthly rewards” button and find to my horror it saying “You have autocontributed 17.5 BAT this month!” Thinking this was an obvious error I go look in my wallet looking for relief but all I find is the measly 0.5 BAT I got from ads this month. Excuse me what?I have never and would never turn on Auto-Contribute, especially THE MOST EXPENSIVE OPTION??

Why did Brave do this, and how do I get my BAT back? Kinda pissed rn probably gonna turn off Rewards altogether if Brave suddenly one morning just tells me to go f myself and takes all the BAT anyways.
How can this issue be reproduced?

  1. Use Brave as normal without any issues
  2. Suddenly lose 18 BAT for no reason due to Auto-Contribute BS
  3. Done

Expected result: Lose all your BAT reward progress

Brave Version( check About Brave):
Version 1.21.73 Chromium: 89.0.4389.72 (Official Build) (64-bit)

Additional Information: Images for reference:



Thanks for reporting. I’d like to ask a few questions to start:

  • Do you have multiple devices linked to your Uphold? If so, how many?
  • Can you share a screenshot of your Contributions and Event Log tabs which can be found here brave://rewards-internals/

Thank you in advance!

Sorry if I came off aggressive in my original report, was a bit frustrated.
Sure, AFAIK I haven’t created an Uphold account ( at the very least not linked Brave to one ) so I don’t think that has anything to do with it unless Brave did something behind the scene which I doubt

Screenshot of Contributions and Events tab:
(Cropped events tab to around the data the “contribution” occurred, seemed the most logical)


If relevant, I saw on reddit some guy linking to a page that said to be careful when updating Brave, and that it could put it back on again as a sort of default. I do recall updating to a new Brave version through the browser not too long ago. To be fair I don’t think it should ever be the case that it just switches Auto-Contribute on without warning, but it might solve the “mystery” of how it got activated. I’d still like to ask if there is any action I can take to refund the BAT I had accumulated.

Hi @thomasnyg - what’s the email linked to your Uphold? I can refund.

Auto-contribute is on by default, just to confirm, did you disable it on this device?

I have the EXACT same issue. My auto-contribution was disabled and it got enabled without any warning. Brave is up to date and yes I use it on 1 Windows PC and on 2 MacBook Pros but I have not changed settings on any devices.

1 Like

Sorry for the delayed response.

Firstly as mentioned in the other post I posted a little bit before the one you’re replying to, At the current point in time I don’t have an Uphold account linked to my Brave Browser. Would you prefer I do that first?

For your second question, yes, I have had it off ever since I installed Brave to until just a couple weeks ago when it gave away all my BAT. As mentioned the only reason I can think of for this is it resetting the settings without telling me when I last updated the Browser.

I look forward to your response :slight_smile:
Thomas

Hi Steeven,

I also have the same issue as @thomasnyg. Yesterday, 20 BAT auto-contributed from my Brave Browser without my consent, and I also would like a refund. I switched laptops in February, and it was enabled again, and now I basically lost all my BAT that I had starting from august 2020…

Kind regards,

Andries van der Meer

Please DM the email linked to your account. Thanks in advance!