An error occurred while checking for updates: The download failed. (error code 7: 0x80072F7D -- system level)

Description of the issue:
An error occurred while checking for updates: The download failed. (error code 7: 0x80072F7D – system level)

How can this issue be reproduced?

  1. Go to the about Brave page
  2. Brave can see there’s a new update
  3. Download fails

Expected result:
Brave to update

Brave Version( check About Brave):
Version 1.25.72 Chromium: 91.0.4472.101 (Official Build) (64-bit)

Additional Information:
I have restarted Brave → didn’t work
I have rebooted the computer → didn’t work
The 0x80072F7D error relates to the old TLS 1.0 standards. I have made sure that is enabled → didn’t work
I disabled Malwarebytes web protection → didn’t work

This has never happened on this computer before

Very strange behavior. Are you connected to a VPN at this time? If so, try disconnecting from it and see if the update goes through. Alternatively, you might try downloading the standalone installer from our Github page and run it to apply the latest updates:

No VPN. I have downloaded the “BraveBrowserStandaloneSetup.exe” from Github and will give that a try. BTW, this is a windows x64 machine.

Thanks for the quick reply @Mattches

1 Like

The one you selected should be for x64 machines – let me know how ti shakes out,.

Thanks for your help @Mattches !
I’m updated now to Version 1.25.73 Chromium: 91.0.4472.106 (Official Build) (64-bit). Lets see what happens in the future for the next update.

1 Like

I’m getting this error also, on a desktop PC - but not on the laptop. As Brave is a secondary browser, I’ll hold off on trying the standalone installer and see if the problem corrects over the next day or so.

Not sure this could be related, but it appears the install directory changed on the laptop with this update from C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application to C:\Program Files\BraveSoftware\Brave-Browser\Application. Maybe the desktop is having issues with that?

I’ve experienced this — rarely — but more frequently than never. Relevant: this problem did occur updating from 1.25.72 to 1.25.73 on both 32- and 64-bit Windows installations, which appears to be what triggered this specific comment thread. [error code 7: 0x80072F7D – system level]

My solution: I used the latest Brave installation file as @Mattches suggests (from, specifically: BraveBrowserSetupxx dot exe (v1.3.101.0) where “xx” is either “32” or “64” depending on which flavor of processor I’m wrangling.

Repeating: this occurs rarely, but more frequently than never, which is why I have the installation files ready to deploy. Using this method retains preferences, extensions, etc.

1 Like

@redbike9 @Ijump2 thank you for confirming that the standalone installer works for this instance of the issue. These types of errors are always reported to the team for review even they have quick fixes like these.

Thank you all for reporting.

1 Like

The problem persisted, so I ended up doing the standalone installer as you recommended.

1 Like

I’m also having the same problem…

I have downloaded Brave from Github and the version was
Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit)

But I can’t update…

Any suggestions?

That was the wrong build – you should be using this one:

Hi! I had this same error once and I didn’t know why. I closed Brave and it didn’t work still. After a restart it worked fine for me.

That build worked…
Thanks a lot…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.