Amazon Prime / Music says the Brave version of Chrome is outdated, won't function

Thank you for any help you can offer!

Description of the issue
When I try to use Amazon Prime / Unlimited Music I get an error box which states “Update Chrome - We have upgraded and this browser version is no longer supported. Please update your browser or download our desktop player.”

Exact URL of the website in question
https://music.amazon.com/albums/B000VHIRZC?do=play&ref=dm_ws_dp_ald_bb_phfa_xx_xx
(This points to a particular album but all give the same error.)

Did the issue present with default Shields settings? [Default states are: Block: Ads/Trackers, 3rd Party Cookies, 3rd Party Fingerprinting Allow: Encrypt Connections enabled (HTTPS), Scripts] (yes/no)
Yes

Does the site function as expected when Shields are turned off? (yes/no)
No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no)
No

Does the site function as expected when using Chrome? (yes/no)
Yes

What Operating System and Brave version/Build are you using when you encounter the issue?(See the About Brave page in the main menu)
Windows 10; “Brave is up to date
Version 0.66.101 Chromium: 75.0.3770.142 (Official Build) (64-bit)”

@gafisher,
Thank you for bringing this to our attention. I was able to reproduce this issue on my end – however, when using Brave Dev builds, the site worked as intended and I’m able to play music via Prime music without issue.

I think that the fix for this will come “for free” in future updates. Generally, if something doesn’t work in Release and is tested i Nightly/Dev builds and works – the fix that allows it to work will get pushed into release as it moves down the pipeline.