"Amazon Music" complaining about old version of Chrome

Description of the issue:
Amazon Music gives an error when attempting to play music on the site. Error: “Update Chrome
You are using a version of Chrome that will no longer be supported soon. Please update your browser or download our desktop player.” (I am using Brave Version “0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)”).

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Navigate to “https://music.amazon.com/stations” and try and play a music station.

Actual Result (gifs and screenshots are welcome!):

Music does not play after the error message.

Expected result:
Music plays.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS v.10.14.5/Brave v. 0.65.118 Chromium: 75.0.3770.80 (Official Build) (64-bit)

Additional Information:
Error started appearing this week (Sunday?). I am logged into Amazon Prime Music during this process. Thanks.

I’m able to listen to and browse the site without issue – testing using macOS Mojave (latest) on Brave release build. Have you changed your Shields settings for the site at all? Additionally, can you try clearing site data to see if that helps the issue?

  1. Visit https://music.amazon.com/stations
  2. Click the “lock” icon in the address bar, then Site Settings
  3. Select both Clear data and Reset Permissions
  4. Relaunch the browser

Hi, just tried your suggestions (clear data & permissions), no joy, same error and no music play. “Shields” have been off for Amazon Music in my Brave browser for awhile. I also have “Block Autoplay” turned off. Just tried Amazon Music in a regular Chrome browser…all OK there.

Hey Brian, if you toggle “All device recognition allowed/allow all cookies” does that make a difference?

Hi, I have “allow all cookies” set to “allow” for Amazon Music…cannot find the “All device recognition” setting you mention? Thanks.

It was just an idea, did it work?

I’ve got the same problem. Tried a fresh install in a VM as well and disabled every possible security feature. It suddenly started around a week ago and was working fine until then.


  1. Visit https://music.amazon.com/stations
  2. Click the Shields panel in your address bar
  3. The change the bottom protection (Device Recognition) to Allow all Device Recognition
  4. Allow the page to refresh

This is what @fanboynz suggested and was also the next thing I was going to ask. Let me know if this resolves the issue for you.

I’m curious – can you try logging in and viewing the page while using a Private window session (or privage w/tor)?

Its possibly a UA check issue.

Sorry for the delay, was away for a few days. Tried “All device recognition allowed”, did not help. I also tried a Private Window Session and a PWS w/Tor…no help there either. Same “old version” error message and no music play.

Do you know if you have already installed WidevineCDM? You would have done this if you needed to stream online content from sites like Netflix or Hulu. This may also be required from Amazon to use the service.

Amazon Prime Music wasn’t causing the “Missing Plugin” prompt/icon to appear for “Wildevine”, and before I could explore how to install it w/o the install prompt, it appears that today’s/(yesterday’s?) Brave update has FIXED the problem! Version 0.65.121 Chromium: 75.0.3770.100 (Official Build)(64-bit) of Brave is now playing Amazon Prime Music for me. Perhaps Amazon Music is now happy with v…3770.100 of Chrome vs. v…3770.80? Anyway, thanks to all for the suggestions.

1 Like